How do you use the iRobot Create 2, an Ubuntu laptop running ROS Kinetic and a Kinect v1 together?

asked 2016-06-13 17:55:31 -0500

ayan 2016 gravatar image

updated 2016-06-17 05:55:24 -0500

If you know about TurtleBot, scroll down to see my errors when trying to run TurtleBot.
How do you use the iRobot Create 2, an Ubuntu laptop running ROS Kinetic and a Kinect v1 together? I tried so many different methods and they all failed! I have very, very bad knowledge with ROS because I got it a few weeks ago. Can some please help me ASAP???!? And I also want to run RViz and navigate around the house. Thanks! (By the way, I also have rtabmap-ros for Kinect and that works really well, but the Create 2 does not!)
Edit: I also have tried the TurtleBot software, fail--- and some other ones--- fail.
Edit 2: I have tried on a Windows Desktop not running ROS and it works perfectly!
Edit 3: I think most of the errors I get are from catkin_make where I run into cmake errors and stuff like "Package not found: ros/time.h" and some other errors. I also have a Kinect 2 I can work with if my Kinect 1 fails, but the iRobot Create is still not working!!!
Edit 4: I tried catkin_makeing the Turtlebot things (I don't know if it's compatible with a Create 2), but all I get is:

This workspace contains non-catkin packages in it, and catkin cannot build
  a non-homogeneous workspace without isolation.  Try the
  'catkin_make_isolated' command instead.

Then, when I run catkin_make_isolated I get:

error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support must be enabled with the -std=c++11 or -std=gnu++11 compiler options.

Then tons of more errors. I tried running it with both of the options above, but all I get is:

catkin_make_isolated -std=gnu++11
usage: catkin_make_isolated [-h] [-C WORKSPACE] [--source SOURCE]
                            [--build BUILD] [--devel DEVEL] [--merge]
                            [--install-space INSTALL_SPACE] [--use-ninja]
                            [--install] [--force-cmake] [--no-color]
                            [--pkg PKGNAME [PKGNAME ...] | --from-pkg PKGNAME]
                            [--only-pkg-with-deps ONLY_PKG_WITH_DEPS [ONLY_PKG_WITH_DEPS ...]]
                            [-q] [--cmake-args [CMAKE_ARGS [CMAKE_ARGS ...]]]
                            [--make-args [MAKE_ARGS [MAKE_ARGS ...]]]
                            [--catkin-make-args [CATKIN_MAKE_ARGS [CATKIN_MAKE_ARGS ...]]]
                            [--override-build-tool-check]
catkin_make_isolated: error: unrecognized arguments: -std=gnu++11

Edit 5: I have ROS Kinetic Kame so that's probably why nothing at all is supported. I would really like some updates if TurtleBot can work with Kinetic Kame, because it's not for me!
Help please?!??!!???
Edit 6: I'm getting a Kobuki (hopefully later on today) and I made a new forum. Thanks!

-Ayan

edit retag flag offensive close merge delete

Comments

I would appreciate an answer A.S.A.P!!!

ayan 2016 gravatar imageayan 2016 ( 2016-06-13 18:32:41 -0500 )edit