ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Undefined symbol after source ros

asked 2023-08-03 10:00:14 -0500

xavier12358 gravatar image

Hello,

I create my own library with setuptools. When I run the command in terminal :

python3.8

Then I import my library, it works properly.

But if before starting python3.8, I run source /opt/ros/noetic/setup.sh

I get an error when I import the python library :

import vmpbcvt
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: /usr/local/lib/python3.8/dist-packages/vmpbcvt-1.0-py3.8-linux-x86_64.egg/vmpbcvt.cpython-38-x86_64-linux-gnu.so: undefined symbol: _ZN19VisionModuleManager15SetCurrentImageB5cxx11ERN2cv3MatEb

Can you explain me how it could be possible ?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2023-08-08 02:18:36 -0500

xavier12358 gravatar image

Thank you for all you answer.

I finally find the problem. In fact previously I add a library in my catkin workspace build folder, the one I now build externally.

When I source the devel/setup.sh, the library used was not the library located in /us/lib/ ... but the older library in catkin_ws.

Thank you Mike Scheutzow and bluegiraffe-sc for your time.

edit flag offensive delete link more
0

answered 2023-08-05 07:57:19 -0500

Mike Scheutzow gravatar image

updated 2023-08-05 07:58:06 -0500

Most likely some ros package and your "vmpbcvt" pkg both rely on the same shared library, but they want different versions of that library.

If you are trying to use this vmpbcvt pkg inside a ros node, it's going to take more work on your part. I assume the name VisionModuleManager will help you identify the library that conflicts.

One approach would be to uninstall the ros package that pulled in the conflicting library. Your import should then succeed.

Another approach is to run vmpbcvt outside of ros and use some private channel to get data between the two - some people have successfully used the ros rosbridge_suite pkg for this purpose.

edit flag offensive delete link more
0

answered 2023-08-04 02:29:12 -0500

bluegiraffe-sc gravatar image

Hi!

As far as I can see, your problem does not seem to be ROS-related. Have you looked for similar issues (see here and here) on StackOverflow?

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2023-08-03 10:00:14 -0500

Seen: 189 times

Last updated: Aug 08 '23