Ask Your Question
0

ros-underlay `make install` fails in Ubuntu 12.04 [closed]

asked 2012-06-01 17:22:35 -0500

Cody gravatar image

updated 2014-01-28 17:12:32 -0500

ngrennan gravatar image

Output of make install is pastebin'd here: https://paste.lugons.org/show/1746/

Directions followed: http://www.ros.org/wiki/fuerte/Installation/Ubuntu/Source

make install is at end of section 1.5.1

An excerpt of the output follows:

running install_egg_info
Removing /opt/ros/fuerte/lib/python2.7/dist-packages/catkin-0.4.0.egg-info
Writing /opt/ros/fuerte/lib/python2.7/dist-packages/catkin-0.4.0.egg-info
-- Up-to-date: /opt/ros/fuerte/share/catkin/stack.xml
-- Up-to-date: /opt/ros/fuerte/etc/catkin/profile.d/00.catkin.all
-- Up-to-date: /opt/ros/fuerte/etc/catkin/profile.d/00.catkin.sh
-- Up-to-date: /opt/ros/fuerte/etc/catkin/profile.d/00.catkin.bash
-- Up-to-date: /opt/ros/fuerte/etc/catkin/profile.d/00.catkin.zsh
-- Up-to-date: /opt/ros/fuerte/etc/catkin/profile.d/00.catkin.tcsh
-- Up-to-date: /opt/ros/fuerte/etc/catkin/profile.d/00.catkin.csh
CMake Error at catkin/bin/cmake_install.cmake:36 (FILE):
  file INSTALL cannot find "/home/nyx/ros-underlay/catkin/bin/em".
Call Stack (most recent call first):
  catkin/cmake_install.cmake:130 (INCLUDE)
  cmake_install.cmake:37 (INCLUDE)


make: *** [install] Error 1
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2014-08-16 23:55:42.579158

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-06-03 12:14:36 -0500

tfoote gravatar image

Can you make sure that your sources are all up to date, and you don't have old CMakeCaches lying around? catkin/bin/em was removed recently, and running the install commands from scratch in a temp directory worked for me.

edit flag offensive delete link more

Comments

At the time I cleaned the entire build (removed all of /opt/ros/fuerte and ~/ros-underlay) and re-performed all of the instructions with the same result.

Cody gravatar image Cody  ( 2012-06-09 07:14:18 -0500 )edit
0

answered 2012-06-02 07:05:20 -0500

dinamex gravatar image

Just go to the folder with
cd /home/nyx/ros-underlay/catkin/bin
than create the folder
mkdir em
and run the installation again

edit flag offensive delete link more

Comments

This workaround works (I created a file called 'em' instead of a folder), but doesn't explain the actual cause or provide a real fix.

Cody gravatar image Cody  ( 2012-06-02 18:42:49 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2012-06-01 17:22:35 -0500

Seen: 509 times

Last updated: Jun 03 '12