Ask Your Question
0

Kinect demos, ubuntu 12.04, fuerte [closed]

asked 2012-05-09 12:11:53 -0500

updated 2014-01-28 17:12:16 -0500

ngrennan gravatar image

I am trying to install kinect demos package from the ros wiki. but when i run "rosmake nnn" it shows error as shown below:

[ rosmake ] rosmake starting...
[ rosmake ] Packages requested are: ['nnn']
[ rosmake ] Logging to directory /home/pragyan/.ros/rosmake/rosmake_output-20120510-033929
[ rosmake ] Expanded args ['nnn'] to: ['nnn']
[rosmake-0] Starting >>> std_msgs [ make ]
[rosmake-1] Starting >>> sensor_msgs [ make ]
[rosmake-2] Starting >>> roslang [ make ]
[rosmake-3] Starting >>> rosbag [ make ]
[rosmake-2] Finished <<< roslang ROS_NOBUILD in package roslang No Makefile in package roslang
[rosmake-2] Starting >>> roscpp [ make ]
[rosmake-1] Finished <<< sensor_msgs ROS_NOBUILD in package sensor_msgs No Makefile in package sensor_msgs [rosmake-0] Finished <<< std_msgs ROS_NOBUILD in package std_msgs No Makefile in package std_msgs
[rosmake-0] Starting >>> geometry_msgs [ make ]
[rosmake-1] Starting >>> pcl [ make ]
[rosmake-3] Finished <<< rosbag ROS_NOBUILD in package rosbag No Makefile in package rosbag
[rosmake-2] Finished <<< roscpp ROS_NOBUILD in package roscpp No Makefile in package roscpp
[rosmake-1] Finished <<< pcl ROS_NOBUILD in package pcl No Makefile in package pcl
[rosmake-3] Starting >>> rosbuild [ make ]
[rosmake-1] Starting >>> roslib [ make ]
[rosmake-2] Starting >>> rosconsole [ make ]
[rosmake-0] Finished <<< geometry_msgs ROS_NOBUILD in package geometry_msgs No Makefile in package geometry_msgs [rosmake-0] Starting >>> rospy [ make ]
[rosmake-3] Finished <<< rosbuild ROS_NOBUILD in package rosbuild No Makefile in package rosbuild
[rosmake-3] Starting >>> smclib [ make ]
[rosmake-0] Finished <<< rospy ROS_NOBUILD in package rospy No Makefile in package rospy
[rosmake-2] Finished <<< rosconsole ROS_NOBUILD in package rosconsole No Makefile in package rosconsole [rosmake-1] Finished <<< roslib ROS_NOBUILD in package roslib No Makefile in package roslib
[rosmake-2] Starting >>> pluginlib [ make ]
[rosmake-0] Starting >>> bond [ make ]
[rosmake-1] Starting >>> message_filters [ make ]
[rosmake-3] Finished <<< smclib ROS_NOBUILD in package smclib
[rosmake-3] Starting >>> rosservice [ make ]
[rosmake-2] Finished <<< pluginlib ROS_NOBUILD in package pluginlib
[rosmake-1] Finished <<< message_filters ROS_NOBUILD in package message_filters No Makefile in package message_filters [rosmake-0] Finished <<< bond ROS_NOBUILD in package bond
[rosmake-0] Starting >>> bondcpp [ make ]
[rosmake-3] Finished <<< rosservice ROS_NOBUILD in package rosservice No Makefile in package rosservice [rosmake-1] Starting >>> bullet [ make ]
[rosmake-2] Starting >>> angles [ make ]
[rosmake-3] Starting >>> dynamic_reconfigure [ make ]
[rosmake-2] Finished <<< angles ROS_NOBUILD in package angles
[rosmake-0] Finished <<< bondcpp ROS_NOBUILD in package bondcpp
[rosmake-1] Finished <<< bullet ROS_NOBUILD in package bullet
[rosmake-3] Finished <<< dynamic_reconfigure ROS_NOBUILD in package dynamic_reconfigure
[rosmake-2] Starting >>> rostest [ make ]
[rosmake-0] Starting >>> nodelet [ make ]
[rosmake-1] Starting >>> roswtf [ make ]
[rosmake-3] Starting >>> common_rosdeps [ make ]
[rosmake-0] Finished <<< nodelet ROS_NOBUILD in package nodelet
[rosmake-0] Starting >>> nodelet_topic_tools [ make ]
[rosmake-2] Finished <<< rostest ROS_NOBUILD in package rostest No Makefile in package rostest
[rosmake-3] Finished <<< common_rosdeps ROS_NOBUILD in package common_rosdeps
[rosmake-1] Finished <<< roswtf ROS_NOBUILD in package roswtf No Makefile in package roswtf
[rosmake-1] Starting >>> tf [ make ]
[rosmake-0] Finished <<< nodelet_topic_tools ROS_NOBUILD in package nodelet_topic_tools
[rosmake-1] Finished <<< tf ROS_NOBUILD in package tf
[rosmake-0] Starting >>> pcl_ros [ make ]
[rosmake-0] Finished <<< pcl_ros ROS_NOBUILD in package pcl_ros
[rosmake-0] Starting >>> nnn [ make ]
[ rosmake ] All 5 lines {------------------------------------------------------------------------------- mkdir -p bin cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=rospack find rosbuild/rostoolchain.cmake .. CMake Error: The current CMakeCache.txt directory /home/pragyan/Techiome/SandBox/kinect_demos/mit-ros-pkg/nnn/build/CMakeCache.txt is different than the directory /home/pragyan/Techiome/kinect_demos/mit-ros-pkg/nnn/build where CMakeCache.txt was created. This may result in binaries being created in the wrong place. If you are not sure, reedit the CMakeCache.txt CMake Error: The source "/home/pragyan ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-12-29 13:40:35

Comments

It's saying that you moved the package at some point. Have you tried deleting the build directory and letting rosmake create a new one?

tbh gravatar image tbh  ( 2012-05-21 03:27:16 -0500 )edit

I am having the same issues. I tried deleting it and downloading a new svn from the mit repository but I still get the same error.

MartinW gravatar image MartinW  ( 2012-07-18 14:05:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-08-16 23:41:25 -0500

Barton.Qi gravatar image

I am get the same errors, when i rosmake hand_interaction! we can know from the ROS.org that there are many packages not supported in Fuerte.

edit flag offensive delete link more

Comments

Would you tell me whether are someone have resolve this problem?

Barton.Qi gravatar image Barton.Qi  ( 2012-08-16 23:44:11 -0500 )edit

I have stopped using the nnn package. Some repositories are not maintained/updated as well as others and some just don't get used anymore. I've found lots of support on the pcl/ros tutorials however, I suggest going there! Cheers

MartinW gravatar image MartinW  ( 2012-08-29 12:01:18 -0500 )edit

Question Tools

Stats

Asked: 2012-05-09 12:11:53 -0500

Seen: 808 times

Last updated: Aug 16 '12