Ask Your Question
1

Running catkin over fuerte

asked 2013-04-24 22:10:44 -0500

mpalomino gravatar image

I am using Fuerte over Ubuntu 12.04. I have been building my packages with Rosbuild but now I have to use Catkin as some of the packages that I need are only released for Groovy.

Inside opt/ros/fuerte/share I have a folder named catkin. Do I need to build this package? I have tried but it doesn't have a Makefile.

As I didn't succeeded in building this package I got Catkin source code from GitHub (release for Fuerte) and tried to build it with Rosbuild but It doesn't have a Makefile either.

I have also followed several tutorials for using Catkin in Fuerte but it is not clear to me how to create a Catkin workspace and if this is the origin of my problems. I have tried to follow the instructions at: ros.org/wiki/catkin/Tutorials/create_a_workspace, but I get an error when executing catkin_init_workspace. The system doesn't recognize the command.

Thank you very much in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-04-25 07:15:47 -0500

William gravatar image

I do not recommend using catkin in Fuerte. If you want/need to use catkin then you should update to Groovy. The reason the catkin_init_workspace command is not found is because the version in Fuerte does not have that command.

edit flag offensive delete link more

Comments

Ok. Thank you very much. We will update to Groovy.

mpalomino gravatar image mpalomino  ( 2013-04-26 00:30:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-24 22:10:44 -0500

Seen: 815 times

Last updated: Apr 25 '13