Ask Your Question
3

Problem of install fuerte on Mac

asked 2012-04-24 22:53:42 -0500

Haojun Guan gravatar image

updated 2014-01-28 17:12:05 -0500

ngrennan gravatar image

When i try to run Cmake with:

cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFF

it shows a error

-- +++ catkin -- Could NOT find PY_em (missing: PY_EM) CMake Error at catkin/cmake/empy.cmake:29 (message): Unable to find either executable 'empy' or Python module 'em'... try installing package 'python-empy' Call Stack (most recent call first): catkin/cmake/all.cmake:52 (include) catkin/CMakeLists.txt:12 (include) Anyone can help me to fix it? I am using Mac OS X 10.7.3

edit retag flag offensive close merge delete

Comments

I am sure that i follow the instructions well, and i have install the empy package.

Haojun Guan gravatar imageHaojun Guan ( 2012-04-25 01:22:04 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
1

answered 2012-04-25 02:01:29 -0500

Kevin gravatar image

updated 2012-04-25 02:06:57 -0500

Try these instuctions, I think they are more up to date. I followed them and have gotten pretty far in the installation. Make sure your python path is correct too.

I am getting stuck with PCL (compiling pcl_ros actually). I have also forked rosdistro and am trying to get the homebrew stuff working correctly for pcl, openni, and ps-engine ... but still having issues.

edit flag offensive delete link more
4

answered 2012-04-24 23:35:39 -0500

AHornung gravatar image

Look at the error message in detail: ... Unable to find either executable 'empy' or Python module 'em'... try installing package 'python-empy' ...

Did you follow the installation instructions?

You should also be able to run "pip install empy".

edit flag offensive delete link more
3

answered 2013-01-22 09:14:48 -0500

ians gravatar image

I came across this error when trying to install Groovy on osx 10.7.5 (lion). It turns out python 2.6 was being used instead of 2.7. So i ran:

cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/groovy -DPYTHON_EXECUTABLE=/usr/bin/python2.7 -DSETUPTOOLS_DEB_LAYOUT=OFF

instead. Note the -DPYTHON_EXECUTABLE .

edit flag offensive delete link more
0

answered 2012-11-01 04:29:57 -0500

nckswt gravatar image

Again, I don't have karma to comment:

On a completely different machine, I went through the Fuerte installation instructions and I still can't get ROS to install properly. Can anyone help fix this problem?

cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFF
-- +++ catkin
-- Could NOT find PY_em (missing:  PY_EM) 
CMake Error at catkin/cmake/empy.cmake:29 (message):
  Unable to find either executable 'empy' or Python module 'em'...  try
  installing package 'python-empy'
Call Stack (most recent call first):
  catkin/cmake/all.cmake:51 (include)
  catkin/CMakeLists.txt:12 (include)


-- Configuring incomplete, errors occurred!
edit flag offensive delete link more

Comments

1

The karma limitation is really stupid!!! Along with the character limitations on comments ... however, my ranting aside :)

Kevin gravatar imageKevin ( 2012-11-01 04:57:55 -0500 )edit
1

Did you try: pip install empy

Kevin gravatar imageKevin ( 2012-11-01 05:00:29 -0500 )edit

I did - here's the output of ls /Library/Python/2.7/site-packages/ : PyYAML-3.10-py2.7.egg-info README _yaml.so easy-install.pth em.py em.pyc empy-3.1-py2.7.egg-info hgext mercurial mercurial-2.4_rc-py2.7.egg-info nose ... (a few more packages) ... yaml

nckswt gravatar imagenckswt ( 2012-11-01 08:34:57 -0500 )edit

Fixed it! Looks like /Library/Python/2.7/site-packages/ wasn't on my python path, so I added it and everything works fine now!

nckswt gravatar imagenckswt ( 2012-11-01 10:01:54 -0500 )edit
1

Great!! So you missed step 1.1.3 where you should have added export PYTHONPATH="/usr/local/lib/python2.7/site-packages:/usr/local/lib/python:$PYTHONPATH" or are the instructions missing something?

Kevin gravatar imageKevin ( 2012-11-02 09:35:11 -0500 )edit

I think I did, but in going through the install many times, I didn't realize that export lasted only for that session. Maybe I should have modified my .bash_profile!

nckswt gravatar imagenckswt ( 2012-11-12 07:41:44 -0500 )edit
0

answered 2012-06-06 13:01:59 -0500

Nick Sweet gravatar image

(I don't have enough karma to comment yet - sorry that this is an answer)

I have the exact same problem. I've gisted my output here: https://gist.github.com/2885354

Think it's at all related to the issue I get when I run easy_install?

python version 2.7.1 can't run /usr/bin/easy_install.  Try the alternative(s):

/usr/bin/easy_install-2.5 (uses python 2.5)
/usr/bin/easy_install-2.6 (uses python 2.6)
/usr/bin/easy_install-2.7 (uses python 2.7)

Run "man python" for more information about multiple version support in
Mac OS X.
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-24 22:53:42 -0500

Seen: 5,459 times

Last updated: Jan 22 '13