Ask Your Question
4

ROS on Ubuntu Xenial (16.04)

asked 2016-02-09 00:54:22 -0500

JimmyB gravatar image

Hi,

Is ROS (Indigo or Jade) compatible with Ubuntu 16.04? If yes, is there some additional steps to install it? If no, when will it be?

Best, Jimmy

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
1

answered 2016-02-09 04:03:43 -0500

tfoote gravatar image

Supported platforms are documented here: http://www.ros.org/reps/rep-0003.html

Updates for Kinetic are in a PR here: https://github.com/ros-infrastructure... and Kinetic will support Xenial

edit flag offensive delete link more
3

answered 2016-06-13 11:41:23 -0500

jbohren gravatar image

You can run ROS Indigo on Xenial pretty easily with Docker using the following: https://github.com/jbohren/rosdocked

edit flag offensive delete link more

Comments

Can you use the same method to run ROS Jade on Xenial?

andrestoga gravatar imageandrestoga ( 2016-08-06 18:21:06 -0500 )edit

Well, yes. But you wouldn't really be "running ROS Jade on Xenial". The docker image would be based on Trusty or Utopic or Vivid.

gvdhoorn gravatar imagegvdhoorn ( 2016-08-13 03:39:03 -0500 )edit
0

answered 2016-02-09 01:47:31 -0500

yasagitov gravatar image

Xenial (16.04) is not released yet. Even if it was officially released both Indigo and Jade is not officially compatible. I think support of Xenial will only be available in ROS Kinetic Kame (which is scheduled on May, 2016).

edit flag offensive delete link more
0

answered 2017-05-12 02:04:39 -0500

Germain gravatar image

Please follow the instruction of installing from the source, I succeed in installing from source.

edit flag offensive delete link more
-1

answered 2017-03-30 08:06:30 -0500

NataliaDiazRodr gravatar image

Is nowadays ROS Indigo compatible with Ubuntu 14.04 (Xenial)? still getting the error E: Unable to locate package ros-indigo-desktop-full

edit flag offensive delete link more

Comments

1

14.04 == Trusty, not Xenial (that is 16.04). Indigo is not supported on 16.04, only on 14.04, so that error is to be expected.

Also: please don't post answers to a question unless you are actually answering it.

gvdhoorn gravatar imagegvdhoorn ( 2017-03-30 10:54:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-02-09 00:54:22 -0500

Seen: 37,447 times

Last updated: Jun 13 '16