Ask Your Question
0

Cannot Install Any More Foxy or Ubuntu Packages

asked 2021-08-12 17:31:18 -0500

Ed C. gravatar image

updated 2021-08-12 19:08:51 -0500

Background

I can't install any packages on a functioning TB3 Waffle with an Intel NUC replacing the Raspberry Pi. I ran into this problem while integrating Tensorflow with ROS 2 Foxy using Alsora packages. ROS2 Tensorflow.

$ uname -a
Linux hood 5.4.0-80-generic #90-Ubuntu SMP Fri Jul 9 22:49:44 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.2 LTS
Release:    20.04
Codename:   focal

$ echo $ROS_DISTRO
foxy

Problem Log

What follows are the results of an install and update:

$ sudo apt install ros-foxy-vision-msgs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  ros-foxy-vision-msgs
0 upgraded, 1 newly installed, 0 to remove and 544 not upgraded.
Need to get 365 kB of archives.
After this operation, 4,493 kB of additional disk space will be used.
Err:1 http://packages.ros.org/ros2/ubuntu focal/main amd64 ros-foxy-vision-msgs amd64 2.0.0-1focal.20210423.013808404  Not Found [IP: 64.50.233.100 80]
E: Failed to fetch http://packages.ros.org/ros2/ubuntu/pool/main/r/ros-foxy-vision-msgs/ros-foxy-vision-msgs_2.0.0-1focal.20210423.013808_amd64.deb  404  Not Found [IP: 64.50.233.100 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

$ sudo apt-get update
Get:1 http://dl.google.com/linux/chrome/deb stable InRelease [1,811 B]
Hit:2 https://download.docker.com/linux/ubuntu focal InRelease                 
Get:3 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]      
Get:4 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1,101 B]
Get:5 http://packages.ros.org/ros2/ubuntu focal InRelease [4,670 B]            
Hit:6 http://us.archive.ubuntu.com/ubuntu focal InRelease                      
Err:5 http://packages.ros.org/ros2/ubuntu focal InRelease                      
  The following signatures were invalid: EXPKEYSIG F42ED6FBAB17C654 Open Robotics <info@osrfoundation.org>
Get:7 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]     
Hit:8 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu focal InRelease  
Hit:9 https://librealsense.intel.com/Debian/apt-repo focal InRelease           
Get:10 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Get:11 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages [793 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [1,134 kB]
Get:13 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [27.7 kB]
Get:14 http://security.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata [8,424 B]
Get:15 http://security.ubuntu.com/ubuntu focal-security/universe amd64 Packages [636 kB]
Get:16 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [61.1 kB]
Get:17 http://security.ubuntu.com/ubuntu focal-security/universe amd64 c-n-f Metadata [12.1 kB]
Get:18 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2,464 B]
Get:19 http://us.archive.ubuntu.com/ubuntu focal-updates/main i386 Packages [517 kB]
Get:20 http://us.archive.ubuntu.com ...
(more)
edit retag flag offensive close merge delete

Comments

This seems to have been a duplicate of #q379190.

gvdhoorn gravatar image gvdhoorn  ( 2021-08-13 02:46:36 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2021-08-12 19:12:52 -0500

Ed C. gravatar image

Do this to update key (OBSERVATION 3)

curl -s https://raw.githubusercontent.com/ros/rosdistro/master/ros.asc | sudo apt-key add -

edit flag offensive delete link more
0

answered 2021-08-12 17:51:58 -0500

ijnek gravatar image

You have to run

sudo curl -sSL https://raw.githubusercontent.com/ros/rosdistro/master/ros.key -o /usr/share/keyrings/ros-archive-keyring.gpg

See ROS GPG Key Expiration Incident on ROS Discourse for more details

edit flag offensive delete link more

Comments

Thank you for your reply. I tried this and it didn't work. See the OBSERVATION 3 note in my original posting. I didn't read Tiryoh's comment carefully from Kat Scott's original posting. The command should be

curl -s https://raw.githubusercontent.com/ros/rosdistro/master/ros.asc | sudo apt-key add -

Followed by an update

sudo apt update

Now it works.

Ed C. gravatar image Ed C.  ( 2021-08-12 19:05:09 -0500 )edit

Apologies, didn't realise your question had an expandable "more" section. Great that you've solved the problem!

ijnek gravatar image ijnek  ( 2021-08-12 19:24:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-08-12 17:31:18 -0500

Seen: 658 times

Last updated: Aug 12 '21