Ask Your Question
0

ROS Repository apt-get tab completion

asked 2011-02-24 02:42:05 -0500

mjcarroll gravatar image

updated 2014-01-28 17:09:13 -0500

ngrennan gravatar image

I have successfully imported the ROS Ubuntu repositories for my platform, but the bash tab-completion for the ROS packages is not present.

Tab-completion works for other packages in the Ubuntu repositories, and I can apt-get install any of the ROS packages, they just don't tab complete.

Is there any way to fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-02-24 04:16:55 -0500

mjcarroll gravatar image

updated 2011-02-24 04:22:06 -0500

I'm still not entirely sure what the problem is, but running the command:

source /etc/bash_completion

Seems to have fixed the problem.

I have also added it to my ~/.bash_profile file so that it will be fixed on all shells.

edit flag offensive delete link more

Comments

This is odd, but at least it's working. Usually it just works like the other things in the repo.
tfoote gravatar image tfoote  ( 2011-02-24 04:23:13 -0500 )edit
@Tully Foote, it does seem like an odd problem. It has worked with previous combinations of ROS and Ubuntu, but for some reason it didn't work this time around. The only reason that I've asked is that I've seen the behavior on 3 computers now. It may possibly be a Ubuntu release problem.
mjcarroll gravatar image mjcarroll  ( 2011-02-24 04:28:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-02-24 02:42:05 -0500

Seen: 435 times

Last updated: Feb 24 '11