Ask Your Question
0

ROS core commands missing after reinstall

asked 2011-02-26 07:31:31 -0600

Wendelin Reich gravatar image

updated 2014-01-28 17:09:14 -0600

ngrennan gravatar image

Dear all,

after uninstalling ROS and then reinstalling ros-cturtle-pr2all (according to the instructions), all of the ROS core commands are missing on my system (all of rospack, rosmake etc. -- except for roslocate and rosinstall). Indeed, the entire ROS_ROOT directory (/opt/ros/cturtle/ros) is missing. On the other hand, /opt/ros/cturtle/stacks seems to be chock-full with stacks. The apt-get install command returns without errors, and the system claims that pr2all is completely installed.

I use Ubuntu 10.10.

Any ideas how I could get "apt-get" to perform a full (re)installation of ROS? That would be very kind.

Background info: The problem started because of my own stupidity. I seem to have made an unclean uninstall of ros-cturtle-pr2, when I simply deleted /opt/ros recursively as well as ROS files in my home folder. After that I have tried several times and in several ways to uninstall/reinstall ROS (cturtle-base / pr2 / pr2all), using both apt-get install/reinstall and the Ubuntu Software Center. The result is always the same: the installation appears to be successful, but there is no /opt/ros/cturtle/ros directory.

Best, Wendelin

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2011-02-26 07:43:35 -0600

kwc gravatar image

Have you tried "sudo apt-get remove ros-cturtle-ros"? That should clear out everything and let you try again. I would start with something smaller to start, like "sudo apt-get install ros-cturtle-common" (ros + common + common_msgs) to make sure the reinstall is working.

edit flag offensive delete link more

Comments

Yes, that fixed it - first apt-install of ros-cturtle-common, then of ros-cturtle-pr2all on top of it. Seems a bit strange, though. But I don't know how to reproduce the error, and it may be obsolete with the release of diamondback. So thanks!!
Wendelin Reich gravatar imageWendelin Reich ( 2011-02-26 18:45:27 -0600 )edit
0

answered 2011-02-26 09:05:44 -0600

tfoote gravatar image

I don't know the command line invocation but you can trigger a reinstallation in Synaptic by right clicking on the package and selecting "Mark for Reinstallation" which hopefully fix it. Otherwise the uninstall/reinstall suggested by @kwc is also a resonable option.

edit flag offensive delete link more
0

answered 2011-02-27 23:17:41 -0600

dornhege gravatar image

Commandline would be: apt-get install --reinstall <pkg>

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-02-26 07:31:31 -0600

Seen: 799 times

Last updated: Feb 27 '11