ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS packages for Ubuntu 11.04?

asked 2011-04-05 07:10:00 -0600

tjenkins gravatar image

updated 2014-01-28 17:09:29 -0600

ngrennan gravatar image

I was just curious when packages will be available for Ubuntu 11.04 (Natty)?

edit retag flag offensive close merge delete


11.04 is far from stable, I would wait a bit before you switch.
mjcarroll gravatar image mjcarroll  ( 2011-04-05 07:21:58 -0600 )edit
I'd rather be running 10.10, but unfortunately I can only get hardware support for my laptop on 11.04. I'm able to follow the instructions to install ROS from source, but I'm still working through how to add packages and stacks (I'm new to all this).
tjenkins gravatar image tjenkins  ( 2011-04-05 11:41:55 -0600 )edit

3 Answers

Sort by » oldest newest most voted

answered 2011-04-05 11:11:45 -0600

kwc gravatar image

We generally do not spin up debian packages before the official Ubuntu release. Natty is not due for release until April 28th.

edit flag offensive delete link more


Why not? I believe there are many users that upgrade to a new Ubuntu version the day it comes out (it's like Xmas every six months!). Whether that's clever or not is a different question, but they could be saved some trouble if you started building debian packages, say, when the RC comes out.
Martin Günther gravatar image Martin Günther  ( 2011-04-05 21:05:01 -0600 )edit
It takes work to spin up debs for a new Ubuntu release. Dozens of stacks require compatibility patches. These generally come from the community as we try to stick to LTS releases in our own development.
kwc gravatar image kwc  ( 2011-04-06 03:45:05 -0600 )edit
Ok, I understand that, thanks for clarifying. I just thought there was some mysterious reason to intentionally hold back the debian packages until the release date.
Martin Günther gravatar image Martin Günther  ( 2011-04-06 21:12:00 -0600 )edit
Natty debs are now available from the repo at
tfoote gravatar image tfoote  ( 2011-06-07 06:07:47 -0600 )edit

answered 2011-05-02 02:49:01 -0600

Dorian Scholz gravatar image


I just installed ROS diamondback from the maverick apt sources on Ubuntu 11.04. I'm using only very few stacks, but they seem to work fine. Is there any place where tips about ROS on 11.04 are collected? The fixes I needed to make are the following:

1) The package ros-diamondback-geometry depends on renamed packages sip4 (now python-sip) and python-sip4-dev (now python-sip-dev). To resolve this I created dummy packages with the old names, depending on the new packages. For this I used the tool 'equivs' with minimal config files:


Section: misc
Priority: optional
Standards-Version: 3.6.2

Package: sip4
Depends: python-sip
Description: temporary package to satisfy dependencies of Ubuntu 10.10 packages on 11.04


Section: misc
Priority: optional
Standards-Version: 3.6.2

Package: python-sip4-dev
Depends: python-sip-dev
Description: temporary package to satisfy dependencies of Ubuntu 10.10 packages on 11.04

Then create and install these packages:

$ sudo apt-get install equivs
$ equivs-build sip4.conf
$ equivs-build python-sip4-dev.conf
$ sudo dpkg -i sip4_1.0_all.deb python-sip4-dev_1.0_all.deb

2) To get rid of some compile time dependency errors I added a local rosdep.yaml in the ROS_HOME (usually ~/.ros):

    '11.04': libboost-all-dev
    '11.04': libtool libltdl-dev
    '11.04': python-qt4-dev
    '11.04': python-sip-dev

Good luck Dorian

edit flag offensive delete link more

answered 2011-05-20 09:37:53 -0600

Tucker Hermans gravatar image

I have used Dorian's solution for the past few days without issue, until I tried to use pr2_gazebo simulator today. I began to have issues with rosparam in rospy, which appears to have come with xmlrpc changes in python 2.7. To fix this I used update-alternatives to switch my python version to point to python2.6. While this fixed the rosparam issues, I then discovered that PyKDL would not work do to the sip4 version installed on 11.04 being too new and thus having an incompatible API.

In order to install an older version of python-sip4 for to fix this issue, I modified the Maverick">package to depend on python2.6 instead of python and installed it using

dpkg -i python-sip_4.10.1-tucker_amd64.deb

You can download the modified package here.

I have not had any issues with my machine, but you could have issues if other programs are hard coded to python that need python2.7 or things using sip through python2.6, which need sip (PyQT, etc).

edit flag offensive delete link more

Question Tools



Asked: 2011-04-05 07:10:00 -0600

Seen: 2,361 times

Last updated: May 20 '11