Ask Your Question
0

OpenNI Issue? Xiron OS got an event timeout! Process has died.

asked 2012-06-26 02:56:32 -0500

cleros gravatar image

updated 2016-10-24 09:10:47 -0500

ngrennan gravatar image

Hello everyone,

I'm am attempting to get RGBDSLAM working on Ubuntu 11.04 (Natty).

I have used to following links to aid in installing ROS Electric, RGBDSLAM and openni_kinect:

For the RGBDSLAM link I stopped at section 4 (Usage). This is because the terminal command

roslaunch rgbdslam kinect+rgbdslam.launch

lead to only the RGBDSLAM UI to appear; pressing space or enter didn't seem to cause anything to happen.

From here, I decided to test to make sure I could actually use the kinect through openni. I started to follow this and used

roslaunch openni_launch openni.launch

in terminal. The final timeout seems to occur sometimes as I use rviz.

... logging to /home/cleros/.ros/log/89f8eb9e-bf87-11e1-8df5-000c29684d60/roslaunch-ubuntu-10105.log
        Checking log directory for disk usage. This may take awhile.
        Press Ctrl-C to interrupt
        Done checking log file disk usage. Usage is <1GB.

        started roslaunch server http://ubuntu:50032/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /camera/driver/rgb_frame_id
 * /camera/disparity_depth_registered/min_range
 * /camera/driver/rgb_camera_info_url
 * /camera/depth_registered/rectify_depth/interpolation
 * /camera/driver/depth_frame_id
 * /camera/depth/rectify_depth/interpolation
 * /camera/disparity_depth/max_range
 * /rosversion
 * /camera/driver/device_id
 * /camera/driver/depth_camera_info_url
 * /camera/disparity_depth/min_range
 * /camera/disparity_depth_registered/max_range

NODES
  /camera/depth/
    rectify_depth (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    metric (nodelet/nodelet)
    points (nodelet/nodelet)
  /camera/rgb/
    debayer (nodelet/nodelet)
    rectify_mono (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
  /
    camera_nodelet_manager (nodelet/nodelet)
    camera_base_link (tf/static_transform_publisher)
    camera_base_link1 (tf/static_transform_publisher)
    camera_base_link2 (tf/static_transform_publisher)
    camera_base_link3 (tf/static_transform_publisher)
  /camera/
    driver (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
    points_xyzrgb_depth_rgb (nodelet/nodelet)
    disparity_depth (nodelet/nodelet)
    disparity_depth_registered (nodelet/nodelet)
  /camera/ir/
    rectify_ir (nodelet/nodelet)
  /camera/depth_registered/
    rectify_depth (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    metric (nodelet/nodelet)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[camera_nodelet_manager-1]: started with pid [10123]
process[camera/driver-2]: started with pid [10124]
process[camera/rgb/debayer-3]: started with pid [10136]
process[camera/rgb/rectify_mono-4]: started with pid [10148]
process[camera/rgb/rectify_color-5]: started with pid [10161]
process[camera/ir/rectify_ir-6]: started with pid [10173]
process[camera/depth/rectify_depth-7]: started with pid [10195]
process[camera/depth/metric_rect-8]: started with pid [10214]
process[camera/depth/metric-9]: started with pid [10239]
process[camera/depth/points-10]: started with pid [10247]
process[camera/register_depth_rgb-11]: started with pid [10256]
process[camera/depth_registered/rectify_depth-12]: started with pid [10270]
process[camera/depth_registered/metric_rect-13]: started with pid [10295]
process[camera/depth_registered/metric-14]: started with pid [10308]
process[camera/points_xyzrgb_depth_rgb-15]: started with pid [10321]
process[camera/disparity_depth-16]: started with pid [10337]
process[camera/disparity_depth_registered-17]: started with pid [10362]
process[camera_base_link-18]: started with pid [10367]
process[camera_base_link1-19]: started with pid [10368]
process[camera_base_link2-20]: started with pid [10387]
process[camera_base_link3-21]: started with pid [10388]
[ERROR] [1340712730.404773751]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters]
[ERROR] [1340712730.409808584]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/theora/set_parameters]
[ INFO] [1340712732.747229754]: Number devices connected: 1
[ INFO] [1340712732.747448067]: 1. device on bus 001:10 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial ...
(more)
edit retag flag offensive close merge delete

Comments

@nitasgu: According to http://ros.org/wiki/roscore roslaunch automatically starts roscore if roscore isn't going. I'm not sure how to restart roscore (I'm new to ROS) - however I would have assumed several restarts of Ubuntu should have done a restart of roscore?

cleros gravatar imagecleros ( 2012-06-26 15:55:12 -0500 )edit

@Felix Endres: I'm running Ubuntu in VMWare so that may explain the issue. Unfortunately, I don't really have the time at the moment to check to confirm this is the case. Thanks.

EDIT: Appears VMWare was the issue in the end. Thanks again Felix.

cleros gravatar imagecleros ( 2012-06-30 17:38:30 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-06-28 00:15:40 -0500

There are many people having similar problems. I could always get things to work by switching to another usb socket. The driver doesn't work with usb 3 and also not in a virtual machine. Also note that openni_camera (as started by kinect+rgbdslam.launch) and openni_launch may differ and interfer.

edit flag offensive delete link more
0

answered 2012-06-26 14:13:36 -0500

moyashi gravatar image

I've had the same situation, but I could solve it just by restarting roscore.

Did you restart roscore?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-26 02:56:32 -0500

Seen: 497 times

Last updated: Jun 28 '12