ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

create ROS workspace - command not found

asked 2015-09-08 09:56:42 -0500

Dallas Chase gravatar image

I've installed: ROS Indigo Trusty (14.04)

I'm stuck in the ROS installation at 3. Managing your environment

When I run the command:

$ export | grep ROS

The terminal outputs:

$: command not found

The same thing happens when I attempt any of the commands there after on the guide.

Checking ROS Installation

When I run the command:

which roscore

The terminal outputs:


Attempting to uninstall ROS

When I run the command:

sudo apt-get remove ros

The terminal outputs:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ros

Any help would be much appreciated. Thanks!

edit retag flag offensive close merge delete


Is your shell a bash? The first "command not found" error looks odd. apt-get remove ros won't work, because there is no package named ros. To uninstall put the packages you used from the install tutorial.

dornhege gravatar image dornhege  ( 2015-09-08 10:01:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-09-08 10:03:52 -0500

Naman gravatar image

updated 2015-09-08 10:04:42 -0500

The command is export | grep ROS. You have put a $ sign before that, that's why you are getting that error!

edit flag offensive delete link more



This is the solution to the problem, so I converted this to an answer.

dornhege gravatar image dornhege  ( 2015-09-08 10:39:10 -0500 )edit

Question Tools

1 follower


Asked: 2015-09-08 09:56:42 -0500

Seen: 781 times

Last updated: Sep 08 '15