Ask Your Question
0

robot setup tf setup for navigation [closed]

asked 2011-06-01 08:32:08 -0500

a11irap gravatar image

updated 2011-06-17 11:39:21 -0500

mmwise gravatar image

When I try to set an initial pose for 2d navigation RVIZ crashes on me. When I check the tf tree, I see that odom is off to the side and not even connected. /map connects straight to /base_link. What am I doing wrong?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by mmwise
close date 2011-06-17 11:42:45

Comments

What type of robot are you using, and what packages are involved? It would sound as if your base controller/driver is publishing directly base_link to map rather than putting out an odometry.
fergs gravatar imagefergs ( 2011-06-01 09:53:38 -0500 )edit
irobotcreate with a hokuyolaser.I amfollowing this tutorial http://www.princeton.edu/~ctralie/Projects/DukeDusty2/Tutorial/#navigation.I did view_frames again before I set initial pose and it seems like /odom is branching off /map now, but /base_link is branching off /map with the broadcaster /temp.
a11irap gravatar imagea11irap ( 2011-06-01 09:59:10 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
2

answered 2011-06-01 23:26:48 -0500

dornhege gravatar image

The first "temp" publisher is wrong. It says the robot does never move in the map. Remove it totally.

The corresponding tf chain from map->odom->base_link should be produced by odometry and SLAM/localization, not a static_transform_publisher.

edit flag offensive delete link more

Comments

That worked! Thanks a lot man!
a11irap gravatar imagea11irap ( 2011-06-02 16:53:49 -0500 )edit
0

answered 2011-06-01 13:06:08 -0500

a11irap gravatar image

updated 2011-06-01 13:12:23 -0500

here are the transforms in the launch file that i got from the dukedusty2 tutorial

there seems to be no link between map and odometry and odometry and base_link

<node pkg="tf" type="static_transform_publisher" name="temp" args="0 0 0 0 0 0 1 map base_link 50"/>

<!--Base platform is 13cm off of ground!-->
<node pkg="tf" type="static_transform_publisher" name="ground_static_tf_publisher" args="0 0 0.13 0 0 0 1 base_link base_platform 50"/>

<node pkg="tf" type="static_transform_publisher" name="hokuyo_static_tf_publisher"
    args="0.14 0 0.06 0 0 0 1 base_platform base_scan 50"/>
edit flag offensive delete link more
0

answered 2011-06-01 12:40:34 -0500

raphael favier gravatar image

updated 2011-06-01 12:44:47 -0500

following this tuto, try changing the local costmap's global_frame to odom

also, check what the ground_static_tf_publisher node outputs as frames. Check its interaction with map and odom. It sounds suspicious... :)

Raph

edit flag offensive delete link more

Comments

hey raph. i followed the tutorial and made the changes to the local costmap.. this produced the same results. odom is branching off of map with amcl.and base_link is branching off of map with base_link(it was /temp) before.. I am still not sure what you are talking about 'ground_static_tf_publisher
a11irap gravatar imagea11irap ( 2011-06-01 12:53:26 -0500 )edit
0

answered 2011-06-01 10:08:19 -0500

a11irap gravatar image

updated 2011-06-07 12:19:48 -0500

mmwise gravatar image

this is what is says after i roswtf

i am using http://www.princeton.edu/~ctralie/Projects/DukeDusty2/Tutorial/#navigation

Loaded plugin tf.tfwtf
Package: createbot
[rospack] warning: ignoring duplicate "cpp" tag in export block
[rospack] warning: ignoring duplicate "cpp" tag in export block

Static checks summary:

Found 1 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING The following packages have msg/srv-related cflags exports that are no longer necessary
    <export>
        <cpp cflags="..."
    </export>:
 * dynamic_reconfigure: -I${prefix}/msg/cpp -I${prefix}/srv/cpp
 * irobot_create_2_1: -I${prefix}/msg/cpp -I${prefix}/srv/cpp
 * hrl_rfid: -I${prefix}/msg/cpp -I${prefix}/srv/cpp
 * driver_base: -I${prefix}/msg/cpp
 * irobot_create_rustic: -I${prefix}/msg/cpp


Found 1 error(s).

ERROR The following packages have rpath issues in manifest.xml:
 * createbot: found flag "-L/opt/ros/diamondback/stacks/irobot_create_rustic/lib", but no matching "-Wl,-rpath,/opt/ros/diamondback/stacks/irobot_create_rustic/lib"
 * irobot_create_rustic: found flag "-L/opt/ros/diamondback/stacks/irobot_create_rustic/lib", but no matching "-Wl,-rpath,/opt/ros/diamondback/stacks/irobot_create_rustic/lib"

================================================================================
Beginning tests of your ROS graph. These may take awhile...
analyzing graph...
... done analyzing graph
running graph rules...
... done running graph rules
running tf checks, this will take a second...
... tf checks complete

Online checks summary:

Found 2 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING The following node subscriptions are unconnected:
 * /amcl:
   * /initialpose
 * /move_base:
   * /move_base_simple/goal
   * /move_base/cancel

WARNING The following nodes are unexpectedly connected:
 * /temp->/rosout (/rosout)
 * /move_base->/rosout (/rosout)
 * /hokuyo_static_tf_publisher->/rosout (/rosout)
 * /amcl->/rosout (/rosout)
 * /base_link->/rosout (/rosout)
 * /map_server->/rosout (/rosout)
 * /ground_static_tf_publisher->/rosout (/rosout)
 * /scan->/rosout (/rosout)
edit flag offensive delete link more

Comments

hey Matthew, can you post the result of "rosrun tf view_frames" please? I'd like to see your tf tree.
raphael favier gravatar imageraphael favier ( 2011-06-01 12:30:33 -0500 )edit
and it might also come from the configuration files of navigation. can you post them and check the values of the parameter "global_frame" for the global and local costmaps.
raphael favier gravatar imageraphael favier ( 2011-06-01 12:33:28 -0500 )edit
what is the ground_static_tf_publisher node you have? If it outputs tf frames with odom or map, it might interfere with navigation
raphael favier gravatar imageraphael favier ( 2011-06-01 12:36:08 -0500 )edit
global_costmap: global_frame: /map robot_base_frame: base_link update_frequency: 5.0 static_map: true
a11irap gravatar imagea11irap ( 2011-06-01 12:36:58 -0500 )edit
local_costmap: global_frame: map robot_base_frame: base_link update_frequency: 5.0 publish_frequency: 1.0 static_map: false rolling_window: true width: 6.0 height: 6.0 resolution: 0.05
a11irap gravatar imagea11irap ( 2011-06-01 12:37:48 -0500 )edit
i have my pdf of the view_frames saved, but how do i post it here?
a11irap gravatar imagea11irap ( 2011-06-01 12:38:29 -0500 )edit
i'm not too sure about what the ground_static_tf_publisher is.. i took everything from http://www.princeton.edu/~ctralie/Projects/DukeDusty2/Tutorial/ but i am not using RFID
a11irap gravatar imagea11irap ( 2011-06-01 12:40:07 -0500 )edit

Question Tools

Stats

Asked: 2011-06-01 08:32:08 -0500

Seen: 838 times

Last updated: Jun 17 '11