Ask Your Question
1

Navigation problem with COB3, DWAPlanerROS create Fail

asked 2017-07-14 13:42:48 -0600

Shaon Debnath gravatar image

Hi,

I am trying to navigate COB3 using cob_navigation_global.

Environment: Ubuntu 14.04.5, ROS-Indigo I have launched COB3 in Gazebo using cob_bringup_sim and then when I am trying to launch

roslaunch cob_navigation_global 2dnav_ros_dwa.launch

I am getting error like

[ INFO] [1500056989.693549168, 7.436000000]: Using plugin "inflation_layer"
[FATAL] [1500056989.982608166, 7.472000000]: Failed to create the dwa_local_planner/DWAPlannerROS planner, are you sure it is properly registered and that the containing library is built? Exception: According to the loaded plugin descriptions the class dwa_local_planner/DWAPlannerROS with base class type nav_core::BaseLocalPlanner does not exist. Declared types are  base_local_planner/TrajectoryPlannerROS eband_local_planner/EBandPlannerROS
[move_base-53] process has died [pid 5150, exit code 1, cmd /opt/ros/indigo/lib/move_base/move_base cmd_vel:=base/twist_mux/command_navigation odom:=base/odometry_controller/odometry __name:=move_base __log:=/home/shaon/.ros/log/3b552036-68c2-11e7-92c7-184f32ad4b7f/move_base-53.log].
log file: /home/shaon/.ros/log/3b552036-68c2-11e7-92c7-184f32ad4b7f/move_base-53*.log

NOTE: Before everything was working perfectly, For some reason I had to reinstall ubuntu and all other things like ros-indigo etc. from then it is not working anymore. I have tried reinstall everything again. But no luck

Any idea??

Thanks in advance

Shaon Debnath

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2017-07-14 15:37:12 -0600

David Lu gravatar image

DWA is not installed. sudo apt-get install ros-indigo-dwa-local-planner

edit flag offensive delete link more

Comments

Thanks David, you saved my day :) It is working now... But I am receiving some other error, which was not before..

[ INFO] [1500067204.859911323, 89.950000000]: Got new plan
[ WARN] [1500067204.936564734, 89.962000000]: DWA planner failed to produce path.

can you identify the reason?

Shaon Debnath gravatar imageShaon Debnath ( 2017-07-14 16:30:33 -0600 )edit

thanks very much

Qusai gravatar imageQusai ( 2019-08-31 06:46:43 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-07-14 13:42:48 -0600

Seen: 1,720 times

Last updated: Jul 14 '17