Ask Your Question
0

Bottom camera problem

asked 2014-11-07 06:36:36 -0600

green96 gravatar image

updated 2014-11-07 06:55:49 -0600

Hi, I use gazebo 2.2 with ROS package tum_simulator. This is a package with simulator of quadrotor AR Parrot Drone.

I had thought that bottom camera is not working and only front camera is OK, but I noticed that image from bottom camera don't display ground but sky. (strange)

Please check this screen: http://snag.gy/L5Riw.jpg

This is a world from Gazebo and two windows from rviz. Left image is a view from bottom camera :( and right image is a view from front camera. Black shape near window of the house is quadrotors' model.

Have you ever heard abut this problem? Any ideas?

I notice that when I run this node I got some errors, I hope that this is a reason of problems with camera.

Error [SDF.cc:788] Missing element description for [offset]
Error [SDF.cc:788] Missing element description for [drift]
Error [SDF.cc:788] Missing element description for [driftFrequency]
[ INFO] [1415319050.065958118, 659.736000000]: Camera Plugin (ns = /)  <tf_prefix_>, set to ""
[ INFO] [1415319050.244706409, 659.736000000]: Camera Plugin (ns = /)  <tf_prefix_>, set to ""
Error [SDF.cc:788] Missing element description for [accelOffset]
Error [SDF.cc:788] Missing element description for [accelDriftFrequency]
Error [SDF.cc:788] Missing element description for [rateOffset]
Error [SDF.cc:788] Missing element description for [rateDriftFrequency]
Error [SDF.cc:788] Missing element description for [headingOffset]
Error [SDF.cc:788] Missing element description for [headingDriftFrequency]
Error [SDF.cc:788] Missing element description for [driftFrequency]
Error [SDF.cc:788] Missing element description for [driftFrequency]
Error [SDF.cc:788] Missing element description for [offset]
Error [SDF.cc:788] Missing element description for [driftFrequency]
Error [SDF.cc:788] Missing element description for [velocityOffset]
Error [SDF.cc:788] Missing element description for [velocityDriftFrequency]
[ INFO] [1415319050.590175130, 659.736000000]: Using imu information on topic ardrone/imu as source of orientation and angular velocity.

Please help.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-11-08 18:07:52 -0600

updated 2014-11-08 18:09:48 -0600

It was an issue with the orientation of the bottom camera on a urdf file (@green96 found the issue). You can look here for more information.

edit flag offensive delete link more
0

answered 2014-11-09 07:51:54 -0600

green96 gravatar image

updated 2014-11-09 07:52:30 -0600

Thank you for your response :) Could you tell me, do this errors on start have any influence? I find some info that upgrading sdformat will help and resolve it. I don't understand why

sudo apt-get install libsdformat2-dev

doesn't work. There is second option to install if from source but according to this site when I do what is in Prerequisites (on this site) I will get rid of sdformat which I have now and other ROS packages like:

  gazebo2 libsdformat-dev libsdformat1 ros-indigo-desktop-full
  ros-indigo-gazebo-plugins ros-indigo-gazebo-ros ros-indigo-gazebo-ros-pkgs
  ros-indigo-simulators
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-07 06:36:36 -0600

Seen: 1,224 times

Last updated: Nov 09 '14