Ask Your Question
1

Problem with ardrone_driver

asked 2014-06-12 05:09:29 -0600

Michael Panayiotou gravatar image

updated 2014-06-12 05:10:34 -0600

I'm trying to roslaunch ardrone_driver. I have installed the ardrone_autonomy and tum_ardrone packages. when i try to roslaunch ardrone_driver i get this message:

[ardrone_driver-1] process has died [pid 19905, exit code -11, cmd /opt/ros/hydro/ardrone_autonomy/bin/ardrone_driver __name:=ardrone_driver __log:=/home/michael/.ros/log/1b4dd950-f22c-11e3-a388-d0df9a5bc38d/ardrone_driver-1.log]. log file: /home/michael/.ros/log/1b4dd950-f22c-11e3-a388-d0df9a5bc38d/ardrone_driver-1*.log all processes on machine have died, roslaunch will exit shutting down processing monitor... ... shutting down processing monitor complete done

And if i leave it long enough it says:

Timeout when reading navdatas - resending a navdata request on port 5554

If someone knows any solution to this problem i would appreciate the help.

I'm using ROS Hydro on Ubuntu 12.04. The ardrone is an AR Drone 2.0 firmware 2.3.3

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-06-12 07:35:27 -0600

samudra gravatar image

updated 2014-06-13 13:11:13 -0600

Which .launch file from ardone_autonomy did you try to launch?

Just to go over the basic, you start the driver with rosrun ardrone_autonomy ardrone_driver. Make sure your computer is connected to the drone's wi-fi.

edit flag offensive delete link more

Comments

WiFi is on and connected to ardrone.i tried rosrun ardrone_autonomy ardrone_driver and i get this: http://s7.postimg.org/c8xb5atga/Screenshot_from_2014_06_12_15_56_50.jpg I even tried to connect it to my iphone and update it to 2.4.8 but i get stuck as you can see at the picture above.

Michael Panayiotou gravatar imageMichael Panayiotou ( 2014-06-12 08:00:37 -0600 )edit

open up the launch file you are trying to launch in a text editor. You'll see, that it will launch a couple of other nodes. To further investigate which node excactly is dying, you have to open up a couple of terminals and launch each node one after another. Post your findings in your question

Rabe gravatar imageRabe ( 2014-06-12 08:22:40 -0600 )edit

The other option might be to just open up the log file described in your output ;) Usually there is more detailed information there too

Rabe gravatar imageRabe ( 2014-06-12 08:23:50 -0600 )edit

The picture looks OK to me. Can you get data from the drone say, with rostopic echo ardrone/navdata? If you connect to the drone from your phone, disconnect your computer. If you want an example for flying AR.Drone with ROS, there is this tutorial: http://robohub.org/tag/parrot-ar-drone-tutorial/

samudra gravatar imagesamudra ( 2014-06-12 08:55:33 -0600 )edit

i made this video to show you where is the problem. if anyone knows any solution to this i will appreciate the help. https://www.youtube.com/watch?v=q48v_KG5ToM

Michael Panayiotou gravatar imageMichael Panayiotou ( 2014-06-13 06:15:39 -0600 )edit

After you get those lines of [INFO], open *another* terminal, run: "rostopic list". You should see /ardrone/navdata among the output. If you do, the driver works. If you run "rostopic pub -1 /ardrone/reset std_msgs/Empty" you should see the drone LEDs change to red (green if you do it again).

samudra gravatar imagesamudra ( 2014-06-13 09:35:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-12 05:09:29 -0600

Seen: 998 times

Last updated: Jun 13 '14