Ask Your Question
0

Problem with drone simulator // [cvg_sim_test] is not a package or launch file name

asked 2014-10-14 16:07:20 -0600

green96 gravatar image

updated 2014-10-15 09:32:51 -0600

Hi, i tried to install package tum_simulator but I found one problem. When I try to run simulator:

roslaunch cvg_sim_test 3boxes_room.launch

i get:

[cvg_sim_test] is not a package or launch file name

I have ROS fuerte and installed gazebo 1.6, rviz.

I was adding step by step packages: ardrone_autonomy package, joy_node and ardrone_joystick packages, tum_simulator package. I used 'rosmake' and I didn't get any error.

My workspace looks:

przemek@przem:~/fuerte_workspace$ ls ardrone_autonomy sandbox setup.sh simulator_gazebo visualization ardrone_helpers setup.bash setup.zsh tum_simulator

When I call echo $ROS_PACKAGE_PATH I get:

/home/przemek/fuerte_workspace/simulator_gazebo:/home/przemek/fuerte_workspace/sandbox:/opt/ros/fuerte/stacks:/opt/ros/fuerte/share:/opt/ros/fuerte/share/ros:/home/przemek/fuerte_workspace/ardrone_autonomy:/home/przemek/fuerte_workspace/ardrone_helpers:/home/przemek/fuerte_workspace/ardrone_helpers:/home/przemek/fuerte_workspace/tum_simulator

there is almost everything apart from rviz.

Please help me.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-10-16 02:12:10 -0600

ahendrix gravatar image

It looks like the tum_simulator repository has a 'fuerte' branch which includes the cvg_sim_test package. Have you tried that version?

edit flag offensive delete link more

Comments

I was doing exactly what is on http://wiki.ros.org/tum_simulator . So I cloned from git this link:

https://github.com/tum-vision/tum_simulator.git

now I see that it has branch master and below we can find info that it is for hydro.

green96 gravatar image green96  ( 2014-10-16 05:52:26 -0600 )edit

So if i have ros-fuerte I should clone from this link?

https://github.com/tum-vision/tum_simulator/tree/fuerte

(Sorry for double comment but there is limit of characters..)

green96 gravatar image green96  ( 2014-10-16 05:53:31 -0600 )edit

No. You already have a copy of the repository on your machine; you just need to check out the 'fuerte' branch. Try: roscd tum_simulator and git checkout fuerte

ahendrix gravatar image ahendrix  ( 2014-10-16 12:00:18 -0600 )edit

Thank you so much for your help, unfortunately before you wrote your answer I had reinstalled my ROS to Indigo version and just now successfully run simulator. :) So I can't check it, but conclusion is to clone from git using parameter -b, for example: -b indigo

green96 gravatar image green96  ( 2014-10-16 16:27:10 -0600 )edit
0

answered 2014-10-15 15:55:17 -0600

green96 gravatar image

updated 2014-10-15 15:58:27 -0600

I noticed sth else... According to readme file which I found, I tried to:

> 4. Run a simulation by executing a launch file in cvg_test_sim package:
>     roslaunch cvg_sim_gazebo ardrone_testworld.launch

but I got: 
... logging to /home/przemek/.ros/log/f6874134-549f-11e4-95b9-001e65a44a56/roslaunch-przem-24357.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last):
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/__init__.py", line 257, in main
    p.start()
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/parent.py", line 257, in start
    self._start_infrastructure()
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/parent.py", line 206, in _start_infrastructure
    self._load_config()
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/parent.py", line 121, in _load_config
    self.config = roslaunch.config.load_config_default(self.roslaunch_files, self.port, verbose=self.verbose)
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/config.py", line 421, in load_config_default
    loader.load(f, config, verbose=verbose)
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 694, in load
    self._load_launch(launch, ros_config, is_core=core, filename=filename, argv=argv, verbose=verbose)
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 666, in _load_launch
    self._recurse_load(ros_config, launch.childNodes, self.root_context, None, is_core, verbose)
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 630, in _recurse_load
    val = self._include_tag(tag, context, ros_config, default_machine, is_core, verbose)
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 95, in call
    return f(*args, **kwds)
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 549, in _include_tag
    inc_filename = self.resolve_args(tag.attributes['file'].value, context)
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 159, in resolve_args
    return substitution_args.resolve_args(args, context=context.resolve_dict, resolve_anon=self.resolve_anon)
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/substitution_args.py", line 203, in resolve_args
    resolved = _find(resolved, a, args, context)
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslaunch/substitution_args.py", line 139, in _find
    return resolved[0:idx-len(arg)] + r.get_path(args[0]) + resolved[idx:]
  File "/usr/lib/pymodules/python2.7/rospkg/rospack.py", line 190, in get_path
    raise ResourceNotFound(name, ros_paths=self._ros_paths)
**ResourceNotFound: gazebo_ros**
ROS path [0]=/opt/ros/fuerte/share/ros
ROS path [1]=/home/przemek/fuerte_workspace
ROS path [2]=/home/przemek/fuerte_workspace/simulator_gazebo
ROS path [3]=/home/przemek/fuerte_workspace/sandbox
ROS path [4]=/opt/ros/fuerte/stacks
ROS path [5]=/opt/ros/fuerte/share
ROS path [6]=/opt/ros/fuerte/share/ros

what's wrong?

also i can't find folder cvg_test_sim. Launch files which are described here I found in folder:

przemek@przem:~/fuerte_workspace/tum_simulator/cvg_sim_gazebo/worlds_backup$ ls
3boxes_room.world  garching_kitchen.world        wg_collada.world
competition.world  rolling_landscape_120m.world
empty.world        tum_kitchen.world

What is the proper way to run this simulator?

edit flag offensive delete link more

Comments

I am facing exactly the same problem

Hazem gravatar image Hazem  ( 2014-10-16 01:51:07 -0600 )edit

Please read what ahendrix wrote. Finally I run tum_simulator on Indigo, but I am not sure if everything works good. My instruction: http://pastebin.com/RDKyiifk

green96 gravatar image green96  ( 2014-10-16 16:32:49 -0600 )edit

Thanks Ahendrix, I used 'fuerte' branch as you said, and the simulation is working perfect now.

Hazem gravatar image Hazem  ( 2014-10-16 16:46:54 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-10-14 16:00:56 -0600

Seen: 3,069 times

Last updated: Oct 16 '14