Ask Your Question
0

Problem installing gscam

asked 2011-03-18 06:44:25 -0500

Antonio gravatar image

Hi, I'm trying to install the gscam packet for Rovio. I've checked out the package into the directory /opt/ros/diamondback/stacks. When I try to use the command rosmake --rosdep-install gscam I always get this error "mkdir: cannot create directory `build': Permission denied". I've tried to change the permissions of the directory with no results. What is wrong? Thank you

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2011-03-18 07:14:21 -0500

joq gravatar image

Do not modify the /opt/ros install trees. They contain shared binaries, already built for your system.

To add another package and build it from source, see the new package downloading question. In your case, specify /opt/ros/diamondback in place of /opt/ros/cturtle.

edit flag offensive delete link more

Comments

Thank you very much, I follow your suggestion and it works. I can't fix the problem using rosmake on the downloaded package, but I'd like to thanks also GeniusGeeko for the assistance!
Antonio gravatar image Antonio  ( 2011-03-21 13:00:39 -0500 )edit
1

answered 2011-03-18 07:10:56 -0500

updated 2011-03-18 07:56:39 -0500

This assumes you have "source /opt/ros/diamondback/setup.bash" added to the end of ~/.bashrc

  1. sudo gedit /opt/ros/diamondback/setup.sh
  2. Change line
    export ROS_PACKAGE_PATH=/opt/ros/diamondback/stacks
    to
    export ROS_PACKAGE_PATH=/opt/ros/diamondback/stacks:~/ros_packages
  3. mkdir ~/ros_packages && cd ~/ros_packages
  4. svn checkout http://brown-ros-pkg.googlecode.com/svn/trunk/experimental/gscam
  5. restart terminal
  6. rosmake --rosdep-install gscam

Cheers, Bryce

edit flag offensive delete link more

Comments

I just love having all of my installed stacks in one neat place. Its just my opinion though.
GeniusGeeko gravatar image GeniusGeeko  ( 2011-03-18 10:49:31 -0500 )edit
Hi, thank you for your assistance. I follow your suggestion but I still can't solve the problem! Do you have any other suggestion?
Antonio gravatar image Antonio  ( 2011-03-20 02:49:22 -0500 )edit
Are you getting the same error?
GeniusGeeko gravatar image GeniusGeeko  ( 2011-03-20 02:59:03 -0500 )edit
Yes, it's always "mkdir: cannot create directory `build': Permission denied", nothing has changed
Antonio gravatar image Antonio  ( 2011-03-20 06:07:47 -0500 )edit
Try the top steps after you use, "sudo su"
GeniusGeeko gravatar image GeniusGeeko  ( 2011-03-20 08:36:49 -0500 )edit
As super user it can't recognize the command rosmake. I've also tried to reinstall all the binaries but I get always the mkdir error...
Antonio gravatar image Antonio  ( 2011-03-20 11:25:21 -0500 )edit
The permissions problem is a clue that you are going about it wrong.
joq gravatar image joq  ( 2011-03-20 13:56:32 -0500 )edit
But I don't know where's the problem. If I try to compile the stacks alredy present in the diamondback package everything it's ok, the problem it's when I try to add new package from svn. I've checked the enviroment variable and follow the tutorial, but the problem it's still there.
Antonio gravatar image Antonio  ( 2011-03-21 00:50:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-18 06:44:25 -0500

Seen: 1,225 times

Last updated: Mar 18 '11