Ask Your Question
0

Couldn't find executable named drone_stateestimation

asked 2014-03-18 09:04:02 -0600

Tonystark124 gravatar image

updated 2014-03-19 17:04:30 -0600

I am trying to fly the ardrone parrot 2.0 using tum_ardrone ptam module. It is a rospackage, so I had to make it using

       rosmake tum_ardrone

The above compiled with 0 failures. however, when I do the following commad

       rosrun tum_ardrone drone_stateestimation

I get the following error

      [rosrun] Couldn't find executable named drone_stateestimation below

      /home/bojan/fuerte_workspace/tum_ardrone

I tried to google and get a solid pipelined solution to check for the reason for this error and solve it, but I did not get it. Am new to ubuntu, thus your help is much appreicated. This error doesn't seem to be package specific since the same package works fine in another laptop I tested. Am runnign Ubuntu in vmWare. Does that make any difference?

Thanks in advance

UPDATE :

This is the ROS_PACKAGE_PATH as you asked.

/home/bojan/fuerte_workspace:/opt/ros/fuerte/share:/opt/ros/fuerte/stacks

The first path is the path I get after roscd. Please let me know if this information helps.

edit retag flag offensive close merge delete

Comments

1

Please post the output of echo $ROS_PACKAGE_PATH because it sounds like you didn't source your setup.bash on the non-working machine.

BennyRe gravatar image BennyRe  ( 2014-03-18 21:19:12 -0600 )edit
1

ROS in a virtual machine doesn't inevitably lead to problems, but it could when it comes to OpenGL and USB-devices. We always recommend our students to install Ubuntu natively. Nevertheless your current problems does not correspond to a virtual machine issue.

BennyRe gravatar image BennyRe  ( 2014-03-18 21:20:16 -0600 )edit

@BennyRe Please check the edit.

Tonystark124 gravatar image Tonystark124  ( 2014-03-19 17:04:55 -0600 )edit

Hm PATH looks good. Try re-sourcing your setup.bash after running rosmake.

BennyRe gravatar image BennyRe  ( 2014-03-20 21:05:00 -0600 )edit

Opening a new question with more information about this problem isn't a good practice. You would have made this a lot easier if you would have wrote that this executable actually doesn't exist and not only ROS can't find it.

BennyRe gravatar image BennyRe  ( 2014-03-21 02:42:28 -0600 )edit

Benny, am really sorry. I just came to know about the new issue, after exploring for a while. And am new to ubuntu and still learning. So please bare with me if I do post such questions that are related.

Tonystark124 gravatar image Tonystark124  ( 2014-03-21 08:18:07 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-05-12 15:03:51 -0600

mar_max gravatar image

I got the same problem and here is how i solved it. 1) remove the tum_ardrone in your workspace 2)go to https://github.com/tum-vision/tum_ard... 3) and select the branch as "fuerte-devel" because you are using ROS-Fuerte 4) download the tum_ardrone zip folder 5) unzip the folder in your workspace 7) change the name of your folder to tum_ardrone 8) execute command "rosmake tum_ardrone" 9) "cd tum_ardrone" and you see a "bin" folder which means you are ready to execute " rosrun tum_ardrone drone_stateestimation".

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-18 09:04:02 -0600

Seen: 2,075 times

Last updated: May 12 '14