Ask Your Question
0

Trying to run ardrone_driver and stuck on "Checking AR.Drone version"

asked 2014-06-06 15:51:11 -0500

Michael Panayiotou gravatar image

After I installed ROS on my Ubuntu 12.04.4 machine I followed the instructions of this tutorial to install ardrone_autonomy package and tum_ardrone package:

-wiki.ros.org/tum_ardrone-

When I successfully installed all the required packages, I followed the steps to Run the packages with the command rosrun.

Before executing the "rosrun ardrone_autonomy ardrone_driver" command I connected to the ARdrone 2.0 via wifi. The ip address of the drone is 192.168.1.1

When I execute the command "rosrun ardrone_autonomy ardrone_driver" I get stuck on "Checking AR.Drone version"

Any suggestion how to solve this?

FYI: I tested the ardrone with my ipad and the freeflight app and it works perfectly. After testing it I pressed the reset button on the drone (leds flashed and the drone reset) because i read that it might still be paired with the ipad.

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
0

answered 2015-06-30 12:16:57 -0500

Mani gravatar image

You are probably seeing this error because your computer is connected to a LAN network which is configured to use 192.168.1.x IP range. This is the same IP range used by the wireless network created by the AR-Drone. The easy fix would be to disconnect your LAN cable (disable that network) before running the driver. The more advanced fix involves modifying the routing table of your Linux machine. As @z3391384 suggested, you can confirm that the traffic is being routed correctly by using telnet 192.168.1.1 before running the driver.

edit flag offensive delete link more
0

answered 2014-12-18 15:52:25 -0500

I am having the same issue. I can telnet to the drone at 192.168.1.1, but when I try running: rosrun ardrone_autonomy ardrone_driver

I get: Getting AR.Drone version... over and over on the screen..

edit flag offensive delete link more
0

answered 2014-08-05 23:25:38 -0500

What's the IP of your computer?

You may need to hard-code the drone's ip using

rosrun ardrone_autonomy ardrone_driver -ip 192.168.1.1
edit flag offensive delete link more
0

answered 2015-10-24 23:12:30 -0500

hem gravatar image

I was having the same problem... u must have paired with ur iphone once.. so, u need to pair it up with ur pc first.. press the reset button in battery holder place(use a neddle type thing to press it)... then telnet 192.168.1.2( for drone 2.0) or telnet 192.168.1.1( for drone 1.0)

edit flag offensive delete link more
0

answered 2014-08-21 01:18:01 -0500

z3391384 gravatar image

For me, I first open a command window and type telnet 192.168.1.1 before running the driver.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-06-06 15:51:11 -0500

Seen: 1,624 times

Last updated: Oct 24 '15