Ask Your Question
0

error while loading shared libraries ardrone

asked 2013-03-08 11:10:40 -0500

jacky_90 gravatar image

Hello everyone. I needed to pass to Ubuntu 64 bit in order not to have problems with the package ar_track_alvar. I was working with the ardrone_autonomy package, which did work fine until i was on 32 bit. Now, when i launch the node, i get the following error:

fuerte_workspace/ardrone_autonomy/bin/ardrone_driver: error while loading shared libraries: libimage_transport.so: wrong ELF class: ELFCLASS64

and the process dies. Any idea to how to fix this? Thanks in advance!

edit retag flag offensive close merge delete

Comments

did u fix it by any chance?

Kishore Kumar gravatar image Kishore Kumar  ( 2015-07-20 10:31:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-11-16 01:40:36 -0500

tfoote gravatar image

You need to use the correct binaries compiled for the architecture on which you are running.

If you're using debian packages make sure you have the right apt sources setup. If you're compiling it yourself from source, you need to clean your workspace and rebuild everything when you change to a new computer with a different architecture.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-08 11:10:40 -0500

Seen: 295 times

Last updated: Nov 16 '15