Ask Your Question
0

Autoware camera-lidar-calibration Error. [closed]

asked 2020-11-26 04:09:15 -0500

ken_koba gravatar image

updated 2021-01-05 04:39:34 -0500

I trying camera-lidar calibration.
Method is below.
https://autoware.readthedocs.io/en/fe...

But Error when "How to launch" No.3. (An image viewer will be displayed.)
Error message is below.

ERROR: cannot launch node of type [calibration_publisher/calibration_publisher]: calibration_publisher  
ROS path [0]=/opt/ros/melodic/share/ros  
ROS path [1]=/home/ubuntu/autoware_sh/autoware.ai/src/autoware/utilities/autoware_camera_lidar_calibrator  
ROS path [2]=/home/ubuntu/autoware_sh/autoware.ai/install/autoware_msgs/share  
ROS path [3]=/home/ubuntu/autoware_sh/autoware.ai/install/autoware_build_flags/share  
ROS path [4]=/opt/ros/melodic/share  
ERROR: cannot launch node of type [image_processor/image_rectifier]: image_processor  
ROS path [0]=/opt/ros/melodic/share/ros  
ROS path [1]=/home/ubuntu/autoware_sh/autoware.ai/src/autoware/utilities/autoware_camera_lidar_calibrator  
ROS path [2]=/home/ubuntu/autoware_sh/autoware.ai/install/autoware_msgs/share  
ROS path [3]=/home/ubuntu/autoware_sh/autoware.ai/install/autoware_build_flags/share  
ROS path [4]=/opt/ros/melodic/share

How can I solve it?

 OS:ubuntu 18.04
 ROS:melodic
 Platform:Jetson AGX Xavier
 Autoware:1.14.0 (source build)

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by ken_koba
close date 2021-01-07 17:11:17.249428

1 Answer

Sort by » oldest newest most voted
0

answered 2020-12-07 11:06:10 -0500

Josh Whitley gravatar image

This looks like an issue with sourcing. When the instructions say "in a sourced terminal," they mean you must first run:

source ~/your_autoware_workspace/devel/setup.bash
edit flag offensive delete link more

Comments

Thank you for the information.
But Already I tried it and Does not solve.
I'm using the following command and setup.bash, is there a problem?

◆command
cd /home/mypc/autoware.ai/build/autoware_camera_lidar_calibrator/
source devel/setup.bash (Details is below)
roslaunch autoware_camera_lidar_calibrator camera_lidar_calibration.launch
intrinsics_file:=/media/mypc/SSD/calibdata/YYYYMMDD_SSSS_autoware_camera_calibration.yaml
image_src:=/image_raw

◆setup.bash
#!/usr/bin/env bash
# generated from catkin/cmake/templates/setup.bash.in
CATKIN_SHELL=bash
# source setup.sh from same directory as this file
_CATKIN_SETUP_DIR=$(builtin cd "dirname "${BASH_SOURCE[0]}"" > /dev/null && pwd)
. "$_CATKIN_SETUP_DIR/setup.sh"

ken_koba gravatar image ken_koba  ( 2020-12-08 20:02:48 -0500 )edit

You should not cd this file but source it instead:

source /home/mypc/autoware.ai/build/autoware_camera_lidar_calibrator/ source devel/setup.bash

Also, what command are you using to build your workspace?

Josh Whitley gravatar image Josh Whitley  ( 2020-12-28 07:53:14 -0500 )edit

I tried below. But does not solve.
source ~/your_autoware_workspace/devel/setup.bash
and
source /home/mypc/autoware.ai/build/autoware_camera_lidar_calibrator/ source devel/setup.bash

Create the workspace by the following method.
$ mkdir -p autoware.ai/src

I referred to the following.
https://gitlab.com/autowarefoundation...
(How to build.For 1.12.0 and Newer)

ken_koba gravatar image ken_koba  ( 2021-01-04 20:25:52 -0500 )edit

Do not use the build folder in your workspace. You do not need anything from the build folder, only the devel folder.

To build:

$ cd ~
$ mkdir -p autoware.ai/src
$ wget -O autoware.ai.repos "https://gitlab.com/autowarefoundation/autoware.ai/autoware/raw/1.14.0/autoware.ai.repos?inline=false"
$ vcs import src < autoware.ai.repos
$ rosdep update
$ rosdep install -y --from-paths src --ignore-src --rosdistro $ROS_DISTRO
$ AUTOWARE_COMPILE_WITH_CUDA=1 colcon build --cmake-args -DCMAKE_BUILD_TYPE=Release

To run intrinsic calibration:

$ cd ~/autoware.ai
$ source devel/setup.bash
$ rosrun autoware_camera_lidar_calibrator cameracalibrator.py --square SQUARE_SIZE --size MxN image:=/image_topic

After this, continue with instructions from https://autoware.readthedocs.io/en/fe....

Josh Whitley gravatar image Josh Whitley  ( 2021-01-04 21:39:32 -0500 )edit

Thank you for the information.

"To build" is pass.
But "To run intrinsic calibration:" is Error

$ cd ~/autoware.ai  
$ source devel/setup.bash  
bash: devel/setup.bash: No such file or directory.

The contents of the autoware.ai folder are as follows.
/build
/install
/log
/src
/autoware.ai.repos

The source folder certainly does not exist.
Is it a matter of installation?

ken_koba gravatar image ken_koba  ( 2021-01-04 23:35:12 -0500 )edit

@ken_koba please do source install/setup.bash

instead of sourcing from the devel folder

sgermanserrano gravatar image sgermanserrano  ( 2021-01-05 09:48:44 -0500 )edit

Sorry, yes, @sgermanserrano is correct. I forgot we build with colcon instead of catkin.

Josh Whitley gravatar image Josh Whitley  ( 2021-01-05 10:24:55 -0500 )edit

@sgermanserrano,@Josh Whitley
Thank you for the information.
The problem has been resolved.

But could not resize the image_view2 window.
I want to small.
What should i do?
The file I'm using is sample2's extrinsic.bag.

ken_koba gravatar image ken_koba  ( 2021-01-07 02:01:43 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2020-11-26 02:50:29 -0500

Seen: 511 times

Last updated: Jan 05 '21