Ask Your Question
0

undefined parameters [kinematics_file] in urdf.xacro

asked 2020-02-15 01:50:09 -0600

Victor Wu gravatar image

I tried to setup the moveit configuration using the moveit setup assistant and the ur5.urdf.xacro from universal robot ros driver. I cannot even load the file and it complaint [kinematics_file] as undefined parameters.

First, what is this kinematics file? Second, where and how should I specify it or define it? Third, is this the calibration data?

Thank your very much for any help.

Regards, Victor Wu.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-02-15 03:11:32 -0600

Victor Wu gravatar image

updated 2020-02-15 03:12:19 -0600

Sorry mates,

My mistake. All the parameters should be handled in the UR5_robot.urdf.xacro file already.

I withdraw this question.

edit flag offensive delete link more

Comments

How did you "fix" the error?

tropic gravatar image tropic  ( 2020-02-20 15:15:03 -0600 )edit

"fix" the error, yes and no. Yes, the [kinematics_file] parameter (or argument) is set in the file UR5_robot.urdf.xacro. Therefore one should use the ur5_robot.urdf.xacro as the top level file instead of using the ur5.urdf.xacro file. Though I remember reading somewhere gvdhoon has mentioned this before, I cannot remember where. At the same time, I cannot find or there does not exist any documentation explaining the architecture of these files or the structure of which one should be used at what level. No, because I am still struggling at this point of time in trying to construct the suite of launch files to use MoveIt, RViz with this new driver, ur_robot_driver, to control my UR5. There seem a lack of documentation or guidelines on how to do this!

Victor Wu gravatar image Victor Wu  ( 2020-02-20 19:23:54 -0600 )edit

Hello Victor,

I have been trying to use the new ur driver for a ur10e with this tutorial: https://industrial-training-master.re... I ran into the same issue as you

inconsistent namespace redefinitions for xmlns:xacro:
 old: http://ros.org/wiki/xacro
 new: http://wiki.ros.org/xacro (/home/dan/catkin_ws/src/fmauch_universal_robot/ur_description/urdf/ur10_robot.urdf.xacro)
Undefined parameters [kinematics_file] None None

I tried changing my workcell.xacro file to open the ur10_robot.urdf.xacro but the error I get stays the same. Were you able to solve the error by using the ur5_robot.urdf.xacro? You said you still had problems with the launch files and RViz.

Thanks!!

dschimpf gravatar image dschimpf  ( 2020-02-28 12:26:12 -0600 )edit

@dschimpf I am not sure I can be of any help. But it seems you are using ur10 descriptions for your ur10e robot. Although I do not have any e-series robots but I think they are different and cannot share the same descriptions. And I think you need to use the moveit setup assistant to construct your own launch files.

Victor Wu gravatar image Victor Wu  ( 2020-02-29 01:20:50 -0600 )edit

I'm having a similar issue trying to get gazebo to run the UR16e, my error message says Undefined parameters [kinematics_file].

StewartHemm74 gravatar image StewartHemm74  ( 2021-02-11 12:29:26 -0600 )edit
1

I was using this parameter and had been a long time since I updated my system. Everything was working, then it wasn't. I noticed the parameter may have changed to kinematics_parameters_file instead of kinematics_file but I can't find the blame/commit. I'm using the fmauch fork, but you can see the param name here (at least, that is if we're running into the same issue).

jwhendy gravatar image jwhendy  ( 2021-05-21 16:38:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-02-15 01:50:09 -0600

Seen: 432 times

Last updated: Feb 15 '20