Ask Your Question
0

MoveIt! Hydro symbol lookup error (Setup Assistant)

asked 2014-04-18 23:16:40 -0600

adreno gravatar image

updated 2014-04-19 02:43:27 -0600

gvdhoorn gravatar image

Hi,

I am following the moveit tutorial to load pr2.urdf.xacro in MoveIt Setup Assistant. As I click on Load Files I get the following symbol lookup error:

[librospack]: error while executing command /opt/ros/hydro/lib/moveit_setup_assistant/moveit_setup_assistant: symbol lookup error: /opt/ros/hydro/lib/libmoveit_setup_assistant_widgets.so: undefined symbol: _ZN3ros7console5printEPNS0_10FilterBaseEPvNS0_6levels5LevelEPKciS7_S7_z

Any suggestions on fixing this ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-04-20 23:12:02 -0600

fergs gravatar image

If you installed MoveIt from source, I would suggest removing the devel and build folders and rebuilding your workspace from scratch.

If you installed from debs, I would update them. There was an issue with a particular release of ros console quite some time ago, which may mean you have outdated debian files.

edit flag offensive delete link more

Comments

Thanks a lot! update did solved the problem :)

adreno gravatar imageadreno ( 2014-04-24 20:55:31 -0600 )edit

Hi. I've did the suggested (debs) update, followed by an install of ros-hydro-moveit-full, but the symbol lookup error is still occurring. Any other suggestions on fixing this?

BillyG gravatar imageBillyG ( 2014-05-02 06:05:09 -0600 )edit

I also updated the ros installation hand moveit packages but problem remains. Please help.

dinesh_sl gravatar imagedinesh_sl ( 2014-05-18 00:52:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-18 23:16:40 -0600

Seen: 221 times

Last updated: Apr 20 '14