Ask Your Question
0

turtlebot navigation using uwb

asked 2019-09-02 16:33:11 -0500

enthusiast.australia gravatar image

updated 2019-09-02 16:34:01 -0500

Hello everyone. I am using turtlebot 3 burger with kinetic and ubuntu 16.04. I am using ultra wide band sensor for positioning of robot. I have transmitters and a receiver. The receiver in connected with raspberry pi via usb. I am able make a python code which will calculate the distance from each anchor and give me two readings, i-e x and y. The code runs in pi and not in my PC where i have ros master. Now i want to access this data in ros and use it for naavigation. How can i do that? I am not very experienced in ros, so any help/tutorial will be of great help.

edit retag flag offensive close merge delete

Comments

@enthusiast.australia: please mark a question as answered by clicking the checkmark to the left of the answer.

We don't close questions here when they are answered.

gvdhoorn gravatar imagegvdhoorn ( 2019-09-08 10:42:59 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-09-04 02:08:19 -0500

duck-development gravatar image

You have to set the ros masters Adress as the environment var

export ROS_MASTER_URI=http://yourPcIpl:11311

edit flag offensive delete link more

Comments

Where i have to set that? Can you please explain a little what to do and where?

enthusiast.australia gravatar imageenthusiast.australia ( 2019-09-04 03:44:09 -0500 )edit
1

answered 2019-09-03 21:02:56 -0500

danscava gravatar image

Take a look at Running ROS across multiple machines. If the pi is in the same network as your PC, you should be able to run ROS on the pi and publish the position to your PC.

edit flag offensive delete link more

Comments

Yes Pi is in same network as my PC but my PC is master and Pi is host. The Pi is in my turtlebot. i run roscore on my PC and master service is started. Now i start my pi with roslaunch bringup command and do my further work. How should i modify things?

enthusiast.australia gravatar imageenthusiast.australia ( 2019-09-04 03:43:16 -0500 )edit

You should add your PC hostname to the file /etc/hosts of your pi. Add the following line:

192.168.x.x     your-pc-hostname

(Fill with the correct information of your PC's hostname and IP.)

In the /etc/hosts of your PC, add the hostname of the pi

192.168.x.x      your-pi-hostname

ROS_MASTER_URI is an environment variable that determines where your master is located, in the case of your pi, your master is located on the PC, so this variable on the pi should be:

ROS_MASTER_URI=http://your-pc-hostname:11311/

To set this variable, you must use the export command in the terminal, like this:

export ROS_MASTER_URI=http://your-pc-hostname:11311/

This is valid only for the current bash, if you want this automatically set every time you run bash, you should add the line above to the file .bashrc located on your home folder.

danscava gravatar imagedanscava ( 2019-09-04 07:09:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-09-02 16:33:11 -0500

Seen: 40 times

Last updated: Sep 04