how to make move_base assume no map and no obstacles?

asked 2019-10-28 20:52:33 -0600

PG_GrantDare gravatar image

Hi,

I am trying to use move_base for outdoor navigation without obstacle detection and without a map. How is this possible?

Using the setup below I get an error saying my starting position is not in the global costmap?

common_costmap_params

#
map_type: costmap
origin_z: 0.0
z_resolution: 1 # The z resolution of the map in meters/cell.
z_voxels: 2  # The number of voxels to in each vertical column, the height of the grid is z resolution * z voxels.
#

obstacle_range: 6 # The default maximum distance from the robot at which an obstacle will be inserted into the cost map in meters.
raytrace_range: 20 # The default range in meters at which to raytrace out obstacles from the map using sensor data

#
publish_voxel_map: true

footprint: [[1.162, 0.93], [-1.162, 0.93], [-1.162, -0.93], [1.162, -0.93]]
footprint_padding: 0.2
inflation_radius: 1.5  # controls how far away the zero cost point is from the obstacle
cost_scaling_factor: 0.8 # slope of the cost decay curve with respect to distance from the object. lower makes robot stay further from obstacles
footprint_clearing_enabled: true

# observation_sources: laser_scan_sensor

# laser_scan_sensor: {sensor_frame: laser, data_type: PointCloud2, topic: /cloud, marking: true, clearing: true, max_obstacle_height: 2, min_obstacle_height: 0.2}

local

local_costmap:
  global_frame: odom
  robot_base_frame: base_link
  update_frequency: 1.0
  publish_frequency: 2.0
  static_map: false
  rolling_window: true
  width: 20.0
  height: 20.0

global

global_costmap:
  global_frame: odom
  robot_base_frame: base_link
  update_frequency: 10
  publish_frequency: 5
  width: 100.0
  height: 100.0
  static_map: true
  rolling_window: true
  resolution: 0.05
edit retag flag offensive close merge delete

Comments

Please post the exact text of the error message(s)

fergs gravatar imagefergs ( 2019-10-28 21:45:39 -0600 )edit