Ask Your Question
1

libGL error: failed to create drawable

asked 2018-03-29 03:49:56 -0600

Delb gravatar image

updated 2018-04-16 06:45:12 -0600

Hi,

I get this message when rviz or Gazebo crashes when I launch my project. After a lot of reseach I figured that it's related to the graphic drivers but after updating and checking that everything was fine I still get this issue.

Then, thanks to the rviz troubleshooting wiki page I found that by simply turning off the hardware acceleration I don't have issues anymore and rviz and Gazebo always launch without crashing.

At first I was satisfied, but there is a downside : since the hardware acceleration is disabled the performances of Gazebo are significantly reduced which is really annoying. Since I know that the issue comes from the hardware acceleration being enabled or disabled is there any possibility to find an halfway solution by changing the configuration of this hardware acceleration (which I'm not at all familiar with) ?

EDIT:

I exported the project on a much more powerful computer (alienware) and never had the issue once so it was only because of the hardware not powerful enough I guess.

edit retag flag offensive close merge delete

Comments

Is this a VM?

gvdhoorn gravatar imagegvdhoorn ( 2018-03-29 03:56:56 -0600 )edit

No I'm using Ubuntu 16.04 and the graphic card is Intel Ivybridge Mobile

Delb gravatar imageDelb ( 2018-03-29 04:19:02 -0600 )edit

Hm. This could be a driver issue then, as you already note. Do you have problems with other OGRE based 3D applications? Disabling acceleration would not seem like a viable work-around to me.

gvdhoorn gravatar imagegvdhoorn ( 2018-03-29 08:33:38 -0600 )edit

With this computer I only use Ros related applications so I don't really know (in addition I don't really know which applications are using OGRE..), I should try to use moveit! then.

Delb gravatar imageDelb ( 2018-03-29 08:49:49 -0600 )edit

MoveIt does not come with a visualiser. It just ships an RViz plugin. From your question text I get the impression you already tested that.

gvdhoorn gravatar imagegvdhoorn ( 2018-03-29 08:51:19 -0600 )edit

I've found something talking about hardwware acceleration here (page 8 third paragraph) but I'm not sure if it's a similar issue to mine

Delb gravatar imageDelb ( 2018-03-29 08:52:00 -0600 )edit

That's a patent application document. I'm not sure how that is useful here.

gvdhoorn gravatar imagegvdhoorn ( 2018-03-29 08:55:05 -0600 )edit

Well it's talking about an issue using harware acceleration with their application too.

Delb gravatar imageDelb ( 2018-03-29 09:08:56 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-04-16 09:43:47 -0600

Delb gravatar image

The issue hasn't been solved with my current configuration but when exporting my project on a more powerful computer (with a better graphic card) this issue doesn't occur anymore. So the problem only comes from an hardware limitation.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-29 03:49:56 -0600

Seen: 5,252 times

Last updated: Apr 16 '18