ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

JointTrajectoryController ( no p gain specified)

asked 2019-05-01 08:10:07 -0500

joeced gravatar image

updated 2019-05-01 10:59:19 -0500

gvdhoorn gravatar image

hello all, am trying to move multiple joints of my delta robot using JointTrajectoryController ( I am using ROS kinetic) . but i am getting the following error:

No p gain specified for pid. Namespace: /gazebo_ros_control/pid_gains/Motor1_UpperArm1
No p gain specified for pid. Namespace: /gazebo_ros_control/pid_gains/Motor2_UpperArm2
No p gain specified for pid. Namespace: /gazebo_ros_control/pid_gains/Motor3_UpperArm3

The following is my .yaml file in the control package

  # Publish all joint states -----------------------------------
    type: joint_state_controller/JointStateController
    publish_rate: 50  

  # Joint Trajectory Controller -------------------------------
     type: position_controllers/JointTrajectoryController
     # CR: Here is my point, can the urdf/transmission specification be used for joint names?
        - Motor1_UpperArm1
        - Motor2_UpperArm2
        - Motor3_UpperArm3
     p: 10
         i: 1 
         d: 10
    p: 10
        i: 1 
        d: 10
    p: 10
        i: 1 
        d: 10

any idea how to fix this issue? Anyone can attach an exemple of the yaml file to do so?

edit retag flag offensive close merge delete



Please copy-paste the exact error message (or messages if you receive multiple). Paraphrasing makes it much more difficult for us to help you.

If you're using any packages that are publicly available, link and/or mention them. If you are using a specific configuration (or configuration files): describe it/them.

gvdhoorn gravatar image gvdhoorn  ( 2019-05-01 09:20:06 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2019-05-02 12:44:21 -0500

RobinChen gravatar image


I get the similar error message. The following links:

And another link:

I follow the suggestion in links and remove the error message, but my robot collapse in Gazebo.

Note: In the links, they said this is not fatal error ( and I can control my robot in Gazebo with the error message), so I choose to not fixes this error now ;)


edit flag offensive delete link more


hello i tried those two suggestions before but i sstill have the same errors. did it worked with you on gazebo7? or on gazebo 9

joeced gravatar image joeced  ( 2019-05-02 15:13:02 -0500 )edit

Yes. It worked with me on Gazebo 7.15. First, I add myrobot_gazebo/config/gazebo_ros_control_params.yaml with content:

# parameters for Gazebo ROS control plugin
    Joint1: {p: 100.0, i: 0.01, d: 10.0}
    Joint2: {p: 100.0, i: 0.01, d: 10.0}
    Joint3: {p: 100.0, i: 0.01, d: 10.0}
    Joint4: {p: 100.0, i: 0.01, d: 10.0}
    Joint5: {p: 100.0, i: 0.01, d: 10.0}
    Joint6: {p: 100.0, i: 0.01, d: 10.0}

Then, I add following line to my gazebo launch file:

<rosparam file="$(find myrobot_gazebo)/config/gazebo_ros_control_params.yaml" command="load"/>

As I said, it remove error message but cause my robot collapse in Gazebo.


RobinChen gravatar image RobinChen  ( 2019-05-02 16:04:26 -0500 )edit

thank you for your time, it removed my errors. Regards

joeced gravatar image joeced  ( 2019-05-03 02:13:17 -0500 )edit

answered 2019-07-04 01:58:53 -0500

Deastan gravatar image

Maybe that can help:

But I think RobinChen is right. You should add that because I saw an issue like that with the package iiwa_stack from IFL. (

edit flag offensive delete link more

answered 2019-05-01 08:29:06 -0500

AndyZe gravatar image
edit flag offensive delete link more


well this is not my case here i am using joint trajectory controller not position controler

joeced gravatar image joeced  ( 2019-05-01 08:54:30 -0500 )edit

Question Tools



Asked: 2019-05-01 08:10:07 -0500

Seen: 2,276 times

Last updated: May 02 '19