Ask Your Question
0

Error no p gain specified for pid

asked 2019-04-16 14:12:42 -0600

bkti9 gravatar image

updated 2019-04-18 09:46:56 -0600

Hi, I'm using ros-melodic with gazebo on ubuntu 14.04. I have seen similar errors and tried all of them but still unable to solve mine. Here is the text that is stored in config file.


robo:
  joint_state_controller:
    type: joint_state_controller/JointStateController
    publish_rate: 50  

  joint1_position_controller:
    type: position_controllers/JointPositionController
    joint: joint1
    pid_gain:
      p: 10.0
      i: 0.0
      d: 0.1

  joint2_position_controller:
    type: position_controllers/JointPositionController
    joint: joint2
    pid_gain:
      p: 10.0
      i: 0.0
      d: 0.1

  joint3_position_controller:
    type: position_controllers/JointPositionController
    joint: joint_left_up_cap
    pid_gains: {p: 200, i: 0.01, d: 0.001}
  joint4_position_controller:
    type: position_controllers/JointPositionController
    joint: joint_right_up_cap
    pid_gains: {p: 200, i: 0.01, d: 0.001}

As you can see I have tried several formats but none worked out.

edit retag flag offensive close merge delete

Comments

Can you paste in the error so we can see what problem you're having?

billy gravatar imagebilly ( 2019-04-16 21:21:13 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-18 09:51:10 -0600

bkti9 gravatar image

I was able to solve the problem. Its more of format error like said in other posts. In my case it was solved if I write separately (in the same .yaml file):

/robotName/gazebo_ros_controls/pid_gains:
..joint1: {p: 10.0,i: 0.0, d:0.01}

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-04-16 14:12:42 -0600

Seen: 647 times

Last updated: Apr 18 '19