rrbot_gazebo not working

asked 2014-02-11 05:49:57 -0500

duffany1 gravatar image

updated 2014-02-11 05:54:38 -0500

I'm following the ros_control tutorial here: http://gazebosim.org/wiki/Tutorials/1...

When I run the following commands in separate terminals:

$ roslaunch rrbot_gazebo rrbot_world.launch
$ roslaunch rrbot_control rrbot_control.launch 
$ rostopic pub -1 /rrbot/joint1_position_controller/command std_msgs/Float64 "data: 1.5"

The rrbot (pendulum) does not respond to the published command at all. (I run the command after the pendulum has already flopped down from its upright position and settled). Why is this?

I got rrbot from https://github.com/ros-simulation/gaz...

The console output appears normal:

// RRBOT_GAZEBO OUTPUT

Msg Waiting for master.[ INFO] [1392140544.351471734]: Finished loading Gazebo ROS API Plugin.
[1;[ INFO] [1392140544.356248402]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
32mMsg Waiting for master
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.214.131
[ INFO] [1392140544.907960168, 0.022000000]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1392140545.001123322, 0.082000000]: Physics dynamic reconfigure ready.

Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.214.131
spawn_model script started
[INFO] [WallTime: 1392140545.577723] [0.000000] Loading model xml from ros parameter
[INFO] [WallTime: 1392140545.585053] [0.000000] Waiting for service /gazebo/spawn_urdf_model
[INFO] [WallTime: 1392140545.597568] [0.000000] Calling service /gazebo/spawn_urdf_model
[INFO] [WallTime: 1392140546.575019] [0.924000] Spawn status: SpawnModel: Successfully spawned model
[urdf_spawner-4] process has finished cleanly
log file: /home/brandon/.ros/log/dbfaf78e-9343-11e3-82b6-000c2971e847/urdf_spawner-4*.log
[ INFO] [1392140547.197049019, 0.924000000]: LoadThread function completed
[ INFO] [1392140547.234406966, 0.924000000]: Loading gazebo_ros_control plugin
[ INFO] [1392140547.234970405, 0.924000000]: Starting gazebo_ros_control plugin in namespace: /rrbot
[ INFO] [1392140547.236207677, 0.924000000]: gazebo_ros_control plugin is waiting for model URDF in parameter [/robot_description] on the ROS param server.
[ INFO] [1392140548.088383534, 0.924000000]: pluginlib WARNING: In file /mnt/hgfs/cmr/ws/src/gazebo_ros_pkgs/gazebo_ros_control/src/default_robot_hw_sim.cpp PLUGINLIB_DECLARE_CLASS is deprecated, please use PLUGINLIB_EXPORT_CLASS instead. You can run the script 'plugin_macro_update' provided with pluginlib in your package source folder to automatically and recursively update legacy macros.  Base = base_class_type, Derived = derived_class_type
[ INFO] [1392140548.278116071, 0.924000000]: Loaded gazebo_ros_control.

// RRBOT_CONTROL OUTPUT

[INFO] [WallTime: 1392140569.094243] [0.000000] Controller Spawner: Waiting for service controller_manager/load_controller
[INFO] [WallTime: 1392140569.098553] [0.000000] Controller Spawner: Waiting for service controller_manager/switch_controller
[INFO] [WallTime: 1392140569.101649] [0.000000] Controller Spawner: Waiting for service controller_manager/unload_controller
[INFO] [WallTime: 1392140569.109712] [0.000000] Loading controller: joint_state_controller
[INFO] [WallTime: 1392140569.469773] [21.016000] Loading controller: joint1_position_controller
[INFO] [WallTime: 1392140569.878716] [21.397000] Loading controller: joint2_position_controller
[INFO] [WallTime: 1392140569.974356] [21.464000] Controller Spawner: Loaded controllers: joint_state_controller, joint1_position_controller, joint2_position_controller
[INFO] [WallTime: 1392140569.981066] [21.471000] Started controllers: joint_state_controller, joint1_position_controller, joint2_position_controller

// ROSTOPIC PUB OUTPUT

publishing and latching message for 3.0 seconds
edit retag flag offensive close merge delete

Comments

Having also a problem in this tutorials, my urdf_spwaner dies contstantly. Did you also face this problem once?

schultza gravatar imageschultza ( 2014-08-01 03:29:42 -0500 )edit