Ask Your Question
0

Issues with move_base

asked 2015-09-28 14:45:44 -0600

Hi All,

I'm having some problems with move_base with base_local_planner and global_planner. I am using an omnidirectional robot with Mecanum wheels. For some reason, move_base prefers to move forward, only moving in reverse or strafing as a last option if the robot gets too close to an object, even if those motions would work better to reach the goal. Anyone know why that would be?

I also have another odd problem. Occasionally, when making an in-place rotation, move_base sends velocities that are higher than what I specified in the config file. It was my understanding that move_base should be limited to the max and min velocities specified. Does anyone know why it does this?

TrajectoryPlannerROS:
  #Robot config parameters
  acc_lim_x: 1.7
  acc_lim_y: 1.7
  acc_lim_th: 2.5
  max_vel_x: 0.5 
  min_vel_x: 0.05
  max_vel_theta: 0.075
  min_vel_theta: -0.075
  min_in_place_vel_theta: 0.05
  escape_vel: -0.25
  holonomic_robot: true
  y_vels: [-0.5, -0.1, 0.1, 0.5]

  #Goal tolerance parameters
  yaw_goal_tolerance: 0.0872664626
  xy_goal_tolerance: 0.1524 
  latch_xy_goal_tolerance: false

  #forward simulation parameters
  sim_time: 1.7 
  sim_granularity: 0.025
  angular_sim_granularity: 0.025
  vx_samples: 10
  vtheta_samples: 20 
  controller_frequency: 20.0

  #trajectory scoring parameters
  meter_scoring: false
  pdist_scale: 0.7
  gdist_scale: 0.8 
  occdist_scale: 0.01
  heading_lookahead: 0.325
  heading_scoring: false
  heading_scoring_timestep: 0.8
  dwa: false
  publish_cost_grid_pc: false
  global_frame_id: /odom

  #Oscillation prevention parameters
  oscillation_reset_dist: 0.05

  #Global plan parameters
  prune_plan: true
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-09-29 10:56:32 -0600

Naman gravatar image
  1. base_local_planner does not support reverse motions. It only supports forward motions and it will go in reverse if there is no way to go forward and its reverse (or escape) velocity is specified by the parameter escape_vel. If you want the robot to go in reverse direction also, you have to change the base_local_planner and one option for that can be pose_follower.

  2. For in_place_rotation, try using max_rotational_vel and min_in_place_rotational_vel (or min_in_place_vel_theta) parameters.

Naman

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-28 14:45:44 -0600

Seen: 735 times

Last updated: Sep 29 '15