Ask Your Question
0

move_base: failed to create TrajectoryPlannerROS?

asked 2013-08-09 14:23:26 -0500

Hendrik Wiese gravatar image

Hi folks,

I keep getting the following error message while trying to follow the navigation robot setup tutorial:

Failed to create the base_local_planner/TrajectoryPlannerROS planner, are you sure it is properly registered and that the containing library is built? Exception: MultiLibraryClassLoader: Could not create class of type base_local_planner::TrajectoryPlannerROS

[MoveBase-10] process has died [pid 4134, exit code 1, cmd /opt/ros/groovy/stacks/navigation/move_base/bin/move_base __name:=MoveBase __log:=/home/hendrik/.ros/log/a34a5e18-f55d-11e2-9197-0022fb1ea482/MoveBase-10.log]. log file: /home/hendrik/.ros/log/a34a5e18-f55d-11e2-9197-0022fb1ea482/MoveBase-10*.log

It has worked for a while. I don't know what I've done wrong to end up with this. Whatever information you need in order to help me figure out the cause of this problem I'll happily provide if I can.

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-08-10 01:41:18 -0500

Hendrik Wiese gravatar image

Got things working again...

bash# apt-get update
...
bash# apt-get upgrade
...

and restarting roscore, rviz and my stack solved the problem.

edit flag offensive delete link more
0

answered 2014-01-30 07:18:11 -0500

BP gravatar image

It is caused by wrong parameters (propably TrajectoryPlanerROS parameters). Best way to deal with it is to save "good parameters" somewhere by rosparam dump [file_name] and load if something goes wrong by rosparam load [file_name]

ofc. the "apt-get" works too, but it's not really convenient

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-09 14:23:26 -0500

Seen: 485 times

Last updated: Jan 30 '14