Ask Your Question
0

Problem with move_base when reaching the goal

asked 2015-06-02 13:37:31 -0500

zeinab gravatar image

updated 2015-06-02 13:41:59 -0500

Hi,

I am using the navigation stack of ros for a differential wheeled robot. Everything seems to work well but recently when I send a navigation goal to rviz, when the robot gets close to the goal area I get many of these warnings :

WARN: DWA planner failed to produce path. : Got new plan WARN : Off Map 3.041686, 2.039254

The costmap seems ok and the path is clear and the map has successfully always worked like this. I have created the map with gmapping.

I dont know what is the reason for this. Thanks in advance for your help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-06-02 15:37:58 -0500

PT gravatar image

Try to set dwa_local_planner's forward_point_distance to 0?

edit flag offensive delete link more

Comments

Same problem. Thanks a lot, this solved the problem !

elpimous12 gravatar imageelpimous12 ( 2019-06-18 05:25:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-06-02 13:37:31 -0500

Seen: 872 times

Last updated: Jun 02 '15