Ask Your Question
0

Gazebo and move_base problem

asked 2015-05-19 20:07:59 -0500

nouf gravatar image

updated 2015-05-19 20:12:59 -0500

Hello

I'm using Ubuntu 12.04 and ROS fuerte

I' simulating SLAM using gazebo and I followed Learning ROS book.

Now I reached move_base.launch but when I run it, it gave the following errors:

[ WARN] [1432083250.106400281,
919.561000000]: Waiting on transform from /base_footprint to /map to become available before running costmap, tf error:  [ WARN] [1432083251.263770834,
923.948000000]: No laser scan received (and thus no pose updates have been published) for 923.948000 seconds.  Verify that data is being published on the /scan topic.

Although, I proved that the laserscans are published by using:

rostopic echo scan

This is move_base file:

<launch>
  <!-- Run the map server -->
   <node name="map_server" pkg="map_server" type="map_server" args="$(find simulation)/maps/gazebo_map.yaml" output="screen">
</node>
  <include file="$(find amcl)/examples/amcl_diff.launch" >
  </include> 
  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find simulation)/launch/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find simulation)/launch/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find simulation)/launch/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find simulation)/launch/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find simulation)/launch/base_local_planner_params.yaml" command="load" />
  </node>
</launch>

and this is my tf tree:

tf tree

Any idea?

Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-05-20 04:39:51 -0500

It seems that you are missing the map frame, as it does not appear on your tf tree. Try to add the following line to the launch file:

<!-- Place map frame at odometry frame -->
<node pkg="tf" type="static_transform_publisher" name="map_odom_broadcaster"
      args="0 0 0 0 0 0 map odom 100"/>

That worked for me in the past. It includes the transformation from map to odom. Which, in this case, is the same.

Probably, you can do a remap of the odom to map as well but, I am not sure that will work.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-19 20:07:59 -0500

Seen: 473 times

Last updated: May 20 '15