ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

unable to launch pr2 keyboard teleop on hydro

asked 2015-01-27 02:21:28 -0600

zenifed gravatar image

I was trying to launch pr2 keyboard teleop on hydro but I shown the following error

ERROR: cannot launch node of type [pr2_teleop/teleop_pr2_keyboard]: can't locate node [teleop_pr2_keyboard] in package [pr2_teleop]

Did anyone faced the same issue before?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-01-28 13:54:44 -0600

ahendrix gravatar image

This sort of question has been asked and answered many times. There are a few basic possibilities:

  • You've installed pr2_teleop from source, and it hasn't been built
  • You've installed pr2_teleop from debs, and there's a bug in the install command.

In this case, it looks like the second option is the case. I've reported this as a bug: https://github.com/PR2/pr2_apps/issue...

edit flag offensive delete link more
1

answered 2015-01-28 14:26:08 -0600

DevonW gravatar image

updated 2015-01-28 14:26:31 -0600

Thanks @ahendrix and @zenifed for pointing this out. I've updated the repository and re-released the package. These changes will be reflected in 0.5.15 and can be used immediately by cloning the repo.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-01-27 02:21:28 -0600

Seen: 474 times

Last updated: Jan 28 '15