Ask Your Question
2

3dsensor.launch does not have /camera/rgb/image_raw/compressed

asked 2014-08-07 03:19:23 -0600

syaz nyp fyp gravatar image

updated 2014-08-14 01:19:55 -0600

good day everyone.

I'm curious (actually in desperation) on why i'm not able to see

/camera/rgb/image_raw/compressed

node when I launch up..

roslaunch turtlebot_bringup 3dsensor.launch

and output from lsusb and lsusb -t.

I'm using an Asus Xtion Pro Live camera.

Im working on a turtlebot-android project on Ubuntu 12.04, ROS Hydro which has a Teleop app on Play Store. As of now, I'm able to successfully control my turtlebot using the VirtualJoystick but I'm unable to receive the camera view.

The image view is subscribing to:

 /camera/rgb/image_raw/compressed

but my 3dsensor.launch does not show

/camera/rgb/image_raw/compressed

node in the terminal when i launch.

Any help will be greatly appreciated. Thank you :)


my rostopic hz /camera/rgb/image_raw/compressed

$ rostopic hz /camera/rgb/image_raw/compressed
subscribed to [/camera/rgb/image_raw/compressed]
average rate: 28.921
    min: 0.022s max: 0.061s std dev: 0.00743s window: 25
average rate: 29.368
    min: 0.019s max: 0.061s std dev: 0.00667s window: 55
average rate: 29.599
    min: 0.000s max: 0.061s std dev: 0.00720s window: 85
average rate: 29.601
    min: 0.000s max: 0.061s std dev: 0.00738s window: 115
average rate: 29.474
    min: 0.000s max: 0.061s std dev: 0.00683s window: 144
^Caverage rate: 29.666
    min: 0.000s max: 0.061s std dev: 0.00734s window: 153

my rosnode list

$ rosnode list
/android/camera_view
/android/virtual_joystick
/app_manager_sr1_ThinkPad_T430_3169_1412817678
/app_manager_sr1_ThinkPad_T430_3169_1481506645
/app_manager_sr1_ThinkPad_T430_3169_1618152413
/app_manager_sr1_ThinkPad_T430_3169_178461068
/app_manager_sr1_ThinkPad_T430_3169_758011786
/app_manager_sr1_ThinkPad_T430_3169_759738930
/app_manager_sr1_ThinkPad_T430_3169_859751585
/camera/camera_nodelet_manager
/camera/depth_metric
/camera/depth_metric_rect
/camera/depth_points
/camera/depth_rectify_depth
/camera/depth_registered_rectify_depth
/camera/disparity_depth
/camera/disparity_registered_hw
/camera/driver
/camera/points_xyzrgb_hw_registered
/camera/rectify_color
/camera/rectify_ir
/dashboard
/depthimage_to_laserscan
/diagnostic_aggregator_sr1_ThinkPad_T430_3169_225580819
/gateway
/gateway_hub
/mobile_base_nodelet_manager_sr1_ThinkPad_T430_3169_876265176
/pairingApplicationNamePublisher
/pairing_master
/robotNameResolver
/rosout
/rviz_1407977575449025588
/zeroconf/zeroconf_avahi

my rosnode info /android/camera_view

~$ rosnode info /android/camera_view

Node [/android/camera_view]
Publications: 
 * /rosout [rosgraph_msgs/Log]

Subscriptions: 
 * /turtlebot/application/camera/rgb/image_color/compressed_throttle [unknown type]

Services: None


contacting node http://192.168.1.33:56155/ ...
Pid: 19165
Connections:
 * topic: /rosout
    * to: /rosout
    * direction: outbound
    * transport: TCPROS

my output from $ lsusb

   $ lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 15d1:0000  
Bus 003 Device 003: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1d27:0601  
Bus 001 Device 004: ID 0a5c:21e6 Broadcom Corp. 
Bus 001 Device 005: ID 04f2:b2db Chicony Electronics Co., Ltd

my output from $ lsusb -t

   $ lsusb -t
1-1.4:1.2: No such file or directory
1-1.4:1.3: No such file or directory
/:  Bus 04.Port ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-08-07 03:43:19 -0600

ahendrix gravatar image

updated 2014-08-13 00:06:10 -0600

/camera/rgb/image_raw/compressed is a topic, not a node. Topics don't appear in the roslaunch output.

With the 3dsensor.launch file running, you should be able to confirm that a node is publishing on this topic with:

rostopic info  /camera/rgb/image_raw/compressed

This will also tell you if any nodes are subscribed to this topic.

If your nodes and publishing and subscribing to the topic, but the subscriber isn't seeing any data, it may be useful to confirm that data is being published with:

rostopic hz  /camera/rgb/image_raw/compressed

EDIT

The output from your 3dsensor.launch file suggests that there is something wrong with the setup for your sensor. You can try plugging it into a USB2 if you have one, and checking the device permissions. The output of lsusb and lsusb -t may be useful here.

EDIT

It looks like you're using an Asus from within a virtual machine. Given that the openni sensors tend to be sensitive to USB issues and use most of the USB bus bandwidth, I'm not too surprised that it doesn't work. (It probably isn't supported by your virtualization software)

edit flag offensive delete link more

Comments

@ahendrix, i was mistaken about the nodes and topic. I'm aware of that now. thank you. i did the rostopic info /camera/rgb/image_raw/compressed and the publisher itself is camera_nodelet_manager. not /camera/rgb/image_raw/compressed.

syaz nyp fyp gravatar imagesyaz nyp fyp ( 2014-08-07 04:05:18 -0600 )edit
1

Additionally, as far as I know, trying to display /camera/rgb/image_raw/compressed will not work, as that stream is compressed. What you can instead do is rosrun image_transport republish compressed in:=camera/rgb/image_raw out:=/output_topic_name, and subscribing to that output topic...

ahubers gravatar imageahubers ( 2014-08-07 11:28:42 -0600 )edit

@syaz-nyp-fp - can you add the output from lsusb and lsusb -t to your question?

ahendrix gravatar imageahendrix ( 2014-08-07 23:54:01 -0600 )edit

@ahendrix, appreciate your time. have updated the question.

syaz nyp fyp gravatar imagesyaz nyp fyp ( 2014-08-10 20:14:28 -0600 )edit

Sorry - It looks like you tried to add the output from lsusb, but it looks like it failed to post or something.

ahendrix gravatar imageahendrix ( 2014-08-11 13:51:57 -0600 )edit

@ahendrix, I'm sure i did post. I've had my mates to view it too.

syaz nyp fyp gravatar imagesyaz nyp fyp ( 2014-08-12 19:52:56 -0600 )edit

On my system, running the lsusb command gives me output like:

$ lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 138a:0017 Validity Sensors, Inc. 
Bus 003 Device 003: ID 17ef:1010 Lenovo 
Bus 003 Device 004: ID 8087:07dc Intel Corp. 
Bus 003 Device 005: ID 0451:8044 Texas Instruments, Inc. 
Bus 003 Device 006: ID 17ef:100f Lenovo 
Bus 003 Device 007: ID 045e:0750 Microsoft Corp. Wired Keyboard 600

I don't see anything like that in your question.

ahendrix gravatar imageahendrix ( 2014-08-12 20:06:27 -0600 )edit

@ahendrix, i've re-edit and repost. have it the question now. :)

syaz nyp fyp gravatar imagesyaz nyp fyp ( 2014-08-12 21:29:59 -0600 )edit
0

answered 2014-08-12 21:51:28 -0600

paulbovbel gravatar image

Looks like you have the newer version of the Xtion which works with openni2. You might first have to install the openni2 packages sudo apt-get install ros-hydro-openni2*

Make a local copy of 3dsensor.launch, and change the line

<include file="$(find openni_launch)/launch/openni.launch">

to

<include file="$(find openni2_launch)/launch/openni2.launch">

Some of the arguments you see in the include tag under that line may not line up between openni and openni2 as well, so you'd need to update/remove them as necessary.

edit flag offensive delete link more

Comments

Thanks for your time @paulbovbel. But i'm already aware & had openni2 installed and changed the 3dsensor launcher way months back.

syaz nyp fyp gravatar imagesyaz nyp fyp ( 2014-08-12 22:16:38 -0600 )edit

I tried to launch openni2 instead of 3dsensor too but to no avail. The topic

/camera/rgb/image_raw/compressed

is publishing

camera_nodelet_manager

instead of the topic itself which the android app is subscribing to. Not camera_nodelet_manager.

Any suggestions @paulbovbel? :)

syaz nyp fyp gravatar imagesyaz nyp fyp ( 2014-08-12 22:18:43 -0600 )edit
1

That is the correct publisher for that topic. The problem is that the driver isn't able to talk to your device, probably because you're trying to use the openni drivers from inside a virtual machine.

ahendrix gravatar imageahendrix ( 2014-08-13 00:46:22 -0600 )edit

That would do it :) Good eye

paulbovbel gravatar imagepaulbovbel ( 2014-08-13 07:40:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-07 03:19:23 -0600

Seen: 2,245 times

Last updated: Aug 14 '14