Ask Your Question
0

Running ros-diamondback-turtlebot (or anything, really) on the Eee 1215N

asked 2011-07-25 07:13:48 -0500

Alaina gravatar image

updated 2014-01-28 17:10:06 -0500

ngrennan gravatar image

We bought an Asus 1215N Eee PC with the intention of rebuilding our Turtlebot on it. Bizarrely, I can't get the default build of Ubuntu 10.04 to work correctly; in particular, the Broadcom wireless NIC and the Atheros Fast Ethernet interface are not supported. Ubuntu (including the kernel) are now up to date with the software update.

After fighting with it, I used a USB stick and my Mac to download the common-wireless drivers. I can build for the Atheros and Broadcom devices, but I can only make one of them work at a time. Once I got FastE working with common-wireless, I tried to install the default Broadcom hardware drivers... that didn't work either. The driver is active but I am unable to connect to any wi-fi network.

Isn't the 1215N the exact machine that Willow Garage is distributing? If so, does anybody know if a) Asus changed the hardware; or b) there's a simple way to get both network interfaces working at the same time?

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
0

answered 2011-08-04 06:46:04 -0500

tfoote gravatar image

We have updated the ISO to include support for the Asus 1215N-PU27 as well as the 1215N-PU17. Give it a try with the new version. mailing list post

edit flag offensive delete link more
2

answered 2011-07-25 08:14:22 -0500

mmwise gravatar image

updated 2011-07-29 20:42:11 -0500

We've created an ISO for installing the TurtleBot with the proper drivers for the wireless and ethernet card.. please go to http://www.ros.org/wiki/Robots/TurtleBot/diamondback/Robot%20Setup and follow the instruction steps for installing your Asus 1215N.

edit flag offensive delete link more

Comments

Alaina did you get the ISO to work?
mmwise gravatar image mmwise  ( 2011-07-26 05:46:48 -0500 )edit
1

answered 2011-07-29 16:04:35 -0500

Ryan gravatar image

Though we're having no problem with the official ISO, we have received netbooks in the past which despite being identical models purchased at the same time have completely different wireless hardware (some showing the same symptoms you describe).

edit flag offensive delete link more
0

answered 2011-07-28 12:47:49 -0500

Alaina gravatar image

Thanks, Melonee.

I downloaded the image, which has the FastE drivers but not the Broadcom wireless drivers. I used that to connect wired to the network and install the wireless drivers from the Hardware Drivers application under "Administration". I did have to set the root password with a "sudo passwd root" because the turtlebot user wasn't allowed to install hardware drivers.

Just FYI in case you want to tweak that image.

edit flag offensive delete link more

Comments

are you using the 1215N.. we have tested that image several times and it loads both interfaces..
mmwise gravatar image mmwise  ( 2011-07-29 11:24:30 -0500 )edit
0

answered 2011-07-30 10:10:31 -0500

Alaina gravatar image

mwise: Yes, we are using the 1215N. I think it might be the situation Ryan described above: maybe the wireless hardware is different? I had to manually install the Broadcom STA drivers in "Hardware Drivers" to get the wireless to work.

FYI, I also couldn't get the 1215N to boot from the USB stick with the turtlebot-amd64.iso. I was able to boot my HP laptop from that USB stick and install the Turtlebot software on it, so it's not the stick itself. To make it work on the 1215N, I had to burn the Turtlebot image to DVD-R and boot from an external DVD drive. Bizarre.

Would you like me to take an image of my 1215N build and send it to you? Apart from setting a static IP and customizing .bashrc to export ROS_MASTER_URI and ROS_HOSTNAME, it's a virgin install that includes the Broadcom STA drivers.

edit flag offensive delete link more

Comments

Regarding booting from the USB stick: Some BIOSes will read a raw ISO, some won't. If you use the Ubuntu "Startup Disk Creator" on the USB stick with the downloaded ISO as the source file, you should get a stick the 1215N can boot from.
Ryan gravatar image Ryan  ( 2011-07-30 18:44:52 -0500 )edit
That's what was weird: I used the Startup Disk Creator. I tried with another USB stick (8 GB vs my original 32 GB) with the same results. I am very unimpressed with this 1215N. I wonder if I would see the same problems if I ordered a second one.
Alaina gravatar image Alaina  ( 2011-07-31 07:00:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-25 07:13:48 -0500

Seen: 601 times

Last updated: Aug 04 '11