Ask Your Question
1

Lots of delay when trying to teleop with a Turtlebot

asked 2013-01-20 06:12:47 -0500

jd gravatar image

I've got a home made turtlebot. It's using a Create with an old laptop (2GHz Pentium). I'm trying to run the SLAM mapping tutorial which seems to be working fine but I run into a ton of lag while trying to drive around using the keyboard teleop. The robot will be unresponsive for several seconds to a minuet.

What I do is ssh from the workstation to the turtlebot laptop. I run the gmapping app in the ssh terminal. Then I start RViz on the workstation. In another terminal I ssh to the turtlebot and run the keyboard teleop.

edit retag flag offensive close merge delete

Comments

If you run only the keyboard teleop and looks at the rostopic echo, the response is as expected? (try to know if the delay is because of the network or because of what is happening at the PC)

Àngel - IRI gravatar image Àngel - IRI  ( 2013-01-20 08:16:55 -0500 )edit

1 Answer

Sort by » oldest newest most voted
3

answered 2013-01-20 19:49:49 -0500

If you have rviz visualizing map data on your workstation, this can quickly saturate your wireless connection as you have to transmit the map data over WiFi (Depends on the publish frequency and other settings of course). Does it work better if you only use teleop without any visualization? Also, if have set up everything properly, you should be able to start the teleop node on your workstation.

See also this Q/A on compressed/ROI map transfer as it might be relevant.

edit flag offensive delete link more

Comments

Teleop does work better when I'm not doing any visualization so that sounds like it could be the problem. I picked up an Xbox controller to try the joystick teleop. I'm going to connect it directly to the turtlebot so that the wireless doesn't have to send the teleop commands and see if that helps

jd gravatar image jd  ( 2013-01-21 00:29:39 -0500 )edit

I ran the gmapping app without RViz on the workstation and using the joystick teleop. Everything worked great.

jd gravatar image jd  ( 2013-01-21 22:38:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-20 06:12:47 -0500

Seen: 663 times

Last updated: Jan 20 '13