Ask Your Question
4

Unable to contact my own server

asked 2011-06-12 17:58:07 -0500

ccm gravatar image

updated 2014-01-28 17:09:50 -0500

ngrennan gravatar image

I'm in the midst of trying to set up turtlebot and I have encountered this problem.

When I type "roslaunch turtlebot_bringup robot.launch" on my laptop, the following message appears

Unable to contact my own server at [http://10.217.252.66:58698/].
This usually means that the network is not configured properly.

I tried pinging myself and it works. Any ideas what might be wrong? Thanks

edit retag flag offensive close merge delete

Comments

1

How to you check your .bashrc form and how do you find your ROS_IP

Haooo gravatar image Haooo  ( 2016-03-05 16:05:18 -0500 )edit

You can open .bashrc by typing gedit ~/.bashrc in the terminal.

skr_robo gravatar image skr_robo  ( 2016-09-12 17:45:14 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
7

answered 2011-06-12 19:31:10 -0500

ccm gravatar image

updated 2011-06-13 14:02:24 -0500

I solved it. I changed the following in my .bashrc from

export ROS_MASTER_URI=http://10.217.252.66:11311 
export ROS_HOSTNAME=10.217.252.66

to

export ROS_MASTER_URI=http://laptop_name:11311
export ROS_HOSTNAME=laptop_name
edit flag offensive delete link more

Comments

If you wanted to use numbers, you may have needed ROS_IP instead of ROS_HOSTNAME.
Daniel Stonier gravatar image Daniel Stonier  ( 2011-06-13 17:45:23 -0500 )edit

Hi , i am getting the same problem as you said, i am able to get the ping result, but i am unable to run rviz . in that answer laptop_name means user name ?? .

rupendra gravatar image rupendra  ( 2018-11-28 00:08:01 -0500 )edit
3

answered 2016-09-27 02:24:31 -0500

clh01s@163.com gravatar image

you need $ export ROS_HOSTNAME=localhost $ export ROS_MASTER_URI=http://localhost:11311

edit flag offensive delete link more

Comments

how can we add this? Actually i am using ubuntu on macbook via parallels and there is no export about localhost or network settings

muhammedozel gravatar image muhammedozel  ( 2018-10-03 14:31:54 -0500 )edit
1

answered 2019-12-24 00:44:11 -0500

mirchi gravatar image
export ROS_MASTER_URI=http://localhost:11311

export ROS_HOSTNAME=localhost

add these lines in bashrc.

edit flag offensive delete link more
1

answered 2019-03-06 10:45:25 -0500

yaoyao1900 gravatar image

I solved it! You can open .bashrc at first with gedit ~/.bashrc in the terminal and then add the code export ROS_HOSTNAME=localhost export ROS_MASTER_URI=http://localhost:11311 at the end of this .bashrc file.

edit flag offensive delete link more
0

answered 2021-01-28 07:59:08 -0500

everything gravatar image

updated 2021-01-28 08:17:36 -0500

  • You can also write the two needed lines in the terminal (=bash) just to test it at first. Mind that any change is lost when another bash is used.
  • If you put it in the .bashrc instead (recommended), it will be automatically loaded at any start of the bash, therefore the name of that file. To apply changes, you need to:
    • restart the bash or
    • "source" the .bashrc, then you do not need a restart of the bash: source ~/.bashrc.
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-12 17:58:07 -0500

Seen: 23,948 times

Last updated: Jan 28