Ask Your Question
1

openni2.launch fails with ROS Indigo, USB3.0

asked 2014-10-04 16:46:20 -0500

moyashi gravatar image

With my configuration, openni2.launch and openni.launch are fails and I have no idea for the reason.
Could you help me ?

When I launch openni2.launch, I have an error as follows.

process[camera/camera_nodelet_manager-1]: started with pid [11714]
process[camera/driver-2]: started with pid [11735]
Could not open "1d27/0600@1/9": Failed to set USB interface!

My laptop is MacBookPro and it has only USB3.0 ports, No USB2.0 port ...
Someone suggests to use "ASUS Xtion USB 3.0 Hotfix, however it seems that I need Windows OS.
I don't have it.

The configuration is as follows.

  1. OS : Ubuntu 14.04
  2. ROS : Indigo
  3. PC : MacBookPro(USB3.0 x 2, USB2.0 x 0, including Mac OS X and Ubuntu 14.04)
  4. tried packages : openni.launch, openni2.launch
  5. Used device : Xtion Pro Live

What should I do ? Thanks in advance.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-10-05 16:21:10 -0500

paulbovbel gravatar image

For the older xtion (0600), you should definitely be running openni.launch unless you get the hotfix installed. You could try running windows in a VM or using someone else's computer, it's a pretty quick process.

You could also try fiddling with the endpoints.

edit flag offensive delete link more

Comments

My xtion is the older version and openni.launch cannot also work well. It generates error(Failed to set USB Interface!)... Actually, xtion worked with Mac OS X, NiViewer can be shown.

I fiddled with the endpoints but it doesn't work...

Can I get hotfix installed with only Ubuntu ??

moyashi gravatar image moyashi  ( 2014-10-06 00:54:59 -0500 )edit

Not afaik. The error is probably due to USB3 incompatibility. You could also try removing xhci ( http://www.pcl-developers.org/xhci-hc... ), but this seems like a lot more trouble than running windows in a vm.

paulbovbel gravatar image paulbovbel  ( 2014-10-06 08:52:30 -0500 )edit
0

answered 2015-02-19 03:35:45 -0500

Kaplan gravatar image

Try that : roslaunch freenect_launch freenect.launch

if it is not installed yet , run : sudo apt-get install ros-indigo-freenect-launch

edit flag offensive delete link more

Comments

1

I didn't think freenect_launch supported the Xtion PRO: http://wiki.ros.org/freenect_camera#O...

jarvisschultz gravatar image jarvisschultz  ( 2015-02-19 12:36:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-04 16:46:20 -0500

Seen: 1,371 times

Last updated: Feb 19 '15