Ask Your Question
0

Can't set up keys - server times out

asked 2016-02-21 04:20:58 -0500

djsw gravatar image

I'm installing ROS Indigo on a fairly fresh install of Ubuntu 14.04. I try to do step 1.3 and:

sudo apt-key adv --keyserver hkp://pool.sks-keyservers.net --recv-key 0xB01FA116

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.iYA2SKI7oY --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/webupd8team-y-ppa-manager.gpg --keyserver hkp://pool.sks-keyservers.net --recv-key 0xB01FA116

gpg: requesting key B01FA116 from hkp server pool.sks-keyservers.net

gpg: keyserver timed out

gpg: keyserver receive failed: keyserver error

Googling hasn't helped and previous answers on this forum are outdated. I tried to install it a week ago and I got the same error. Any ideas?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-02-23 22:17:50 -0500

djsw gravatar image

Despite the fact that this issue persisted for a week, I tried again today and I did not receive this error. I assume it's the server's fault and there are just days at a time where you can't install ROS.

edit flag offensive delete link more

Comments

1

Unfortunately ROS does not maintain the key servers, and this has been a know issue in the past: https://github.com/ros-infrastructure... . I've updated the tutorials to use the high-availability keyserver pool, which should help.

ahendrix gravatar imageahendrix ( 2016-02-24 01:56:24 -0500 )edit
0

answered 2016-07-10 02:26:34 -0500

est_CEAR gravatar image

Hi,

I got the same issue, but this was due to the internet router securities. Changing the network helps :-)

Hope this helps

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-21 04:20:58 -0500

Seen: 1,550 times

Last updated: Jul 10 '16