ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Ros indigo ubuntu 14.04 asus xtion failed to show picture.

asked 2015-10-15 10:10:07 -0500

p2p345 gravatar image

So I've been playing a little around with the turtlebot and asus xtion pro live, using the provided tutorials.

Everything seems to be working fairly good, except that I can't seem to get a colored picture from the camera.

I'm using the command roslaunch openni2_launch openni2.launch, since the openni library(?) won't work with my xtion edition. But whenever i run the code, i get the error Warning USB events thread - failed to set priority. I know that I'm not the only one getting this, but what I've found on the internet doesn't seem to be working or I might have misunderstood something.

It should also be noted that whenever i run Rviz, I get the pointcloud, but my terminal window, which has the openni2 package running starts to say that it is missing some calibration, could this be my problem or is there some easy fix for it?

Also please note that I'm fairly new to linux/ubuntu.

Hopefully some of you are able to help me.

\Michael V

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-12-27 23:40:25 -0500

zinuok gravatar image

This is because you are using USB 3.0 port for Xtion pro live. You can use 2.0 port rather than the 3.0 port, or just disconnect and re-connect the usb cable.

edit flag offensive delete link more

Question Tools


Asked: 2015-10-15 10:10:07 -0500

Seen: 261 times

Last updated: Oct 15 '15