ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rgbdslam main process segv from roslaunch openni+rgbdslam.launch

asked 2014-09-12 06:28:38 -0500

monkeyiq gravatar image

Hi, I have a kinect attached to an Intel J1900 based machine and the OpenNI examples run fine including the hand tracking example. Using OpenNI and SensorKinect. ( and both on unstable branch). This is an Ubuntu 14.04.1 installation with ROS indigo.

I have rgbdslam installed via catkin as the web page suggests. After some compile and linking glitches I got a binary. However, trying to run:

$ roslaunch rgbdslam openni+rgbdslam.launch

results in the rgbdslam-23 process segving and thus the launch as a whole entering the fail state.

process[rgbdslam-23]: started with pid [8189]
================================================================================REQUIRED process [rgbdslam-23] has died!
process has died [pid 8189, exit code -11, cmd /home/monkeyiq/catkin_ws/devel/lib/rgbdslam/rgbdslam __name:=rgbdslam __log:=/home/monkeyiq/.ros/log/7f7c8758-3a90-11e4-8b1b-d050992ba7ab/rgbdslam-23.log].                                                                                                                    
log file: /home/monkeyiq/.ros/log/7f7c8758-3a90-11e4-8b1b-d050992ba7ab/rgbdslam-23*.log

Initiating shutdown!

Unfortunately the Logs do not seem to shine light on any specific cause.

I'm not sure if its a good idea to try to gdb the rgbdslam executable directly, but this is what I get when that segvs:

~/catkin_ws/src/rgbdslam_v2/launch$ gdb /home/monkeyiq/catkin_ws/devel/lib/rgbdslam/rgbdslam
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7582a8c in boost::math::lanczos::lanczos_initializer<boost::math::lanczos::lanczos17m64, long double>::init::init() ()
   from /usr/lib/
(gdb) bt
#0  0x00007ffff7582a8c in boost::math::lanczos::lanczos_initializer<boost::math::lanczos::lanczos17m64, long double>::init::init() ()
   from /usr/lib/
#1  0x00007ffff750d186 in ?? () from /usr/lib/
#2  0x00007ffff7dea13a in call_init (l=<optimised out>, argc=argc@entry=1, argv=argv@entry=0x7fffffffe138, env=env@entry=0x7fffffffe148) at dl-init.c:78
#3  0x00007ffff7dea223 in call_init (env=<optimised out>, argv=<optimised out>, argc=<optimised out>, l=<optimised out>) at dl-init.c:36
#4  _dl_init (main_map=0x7ffff7ffe1c8, argc=1, argv=0x7fffffffe138, env=0x7fffffffe148) at dl-init.c:126
#5  0x00007ffff7ddb30a in _dl_start_user () from /lib64/
#6  0x0000000000000001 in ?? ()
#7  0x00007fffffffe3d5 in ?? ()
#8  0x0000000000000000 in ?? ()
(gdb) q

Any thoughts or recommendations are greatly appreciated.

edit retag flag offensive close merge delete


This appears to be a clash with boost and your selected c++ standard during various compiles. Removing the -std=c++0x from catkin_ws/src/rgbdslam_v2/CMakeLists.txt no longer crashes in the same way. Shortly I will verify that the DSLAM as a whole is doing something productive now.

monkeyiq gravatar image monkeyiq  ( 2014-09-14 07:57:31 -0500 )edit

I have a similar problem. May I ask how did you compile without -std=c++0x ? it seems some components are forced to be compiled under C++11.

Noahsark gravatar image Noahsark  ( 2014-10-12 16:58:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-09-18 06:48:31 -0500

monkeyiq gravatar image

removing the -std=c++0x from the catkin_ws/src/rgbdslam_v2/CMakeLists.txt got the GUI to appear. Hope this helps somebody else sometime.

edit flag offensive delete link more


yes, it helped me. Thanks!

Pat gravatar image Pat  ( 2014-09-25 23:50:33 -0500 )edit

When I remove -std=c++0x , the compilation gives a lambda error. doesn't happen to you?

Dinl gravatar image Dinl  ( 2015-12-16 22:35:09 -0500 )edit

Question Tools



Asked: 2014-09-12 06:28:38 -0500

Seen: 882 times

Last updated: Sep 18 '14