Ask Your Question
0

Refer to installed PCL (ARM)

asked 2013-10-30 00:24:24 -0500

RodBelaFarin gravatar image

updated 2014-01-28 17:18:23 -0500

ngrennan gravatar image

Hi,

i was able to install PCL 1.7.0 on my ARM based PandaBoard.

If I now try to install different ROS stacks that depend on PCL it is always telling me that ROS is not able to find PCL. (I tried for example to install RGBD, Navigation, viso2_ros...)

Could anyone explain how do I refer to the PCL in the right way so that it is found by ROS?

edit retag flag offensive close merge delete

Comments

What version of ROS are you trying to use?

tfoote gravatar imagetfoote ( 2013-11-14 10:48:22 -0500 )edit

i used ROS groovy, but i upgraded now to hydro and there it works fine!

RodBelaFarin gravatar imageRodBelaFarin ( 2013-11-15 01:21:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-11-15 06:32:30 -0500

tfoote gravatar image

Yeah, In Groovy ROS uses a custom packaged version of PCL. In Hydro it uses the system installed version. So upgrading to Hydro is the easiest solution.

edit flag offensive delete link more

Comments

upgrading to hydro was really the best thing that i could do on my arm pandaboard. most things work fine, but it's stillt not perfect. today i tried to install ccny and i get again the error that PCL is not found, cause i have to built that on my own. any ideas to set THIS one to the right refer?

RodBelaFarin gravatar imageRodBelaFarin ( 2013-11-16 02:55:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-30 00:24:24 -0500

Seen: 385 times

Last updated: Nov 15 '13