Ask Your Question
0

Install RGBDSLAM on ARM

asked 2016-04-02 12:52:50 -0500

jacksonkr_ gravatar image

updated 2016-04-05 20:39:47 -0500

I've installed RGBDSLAM on a number of computers but ARM is proving to be a bit more challenging. I'm trying to install RGBDSLAM on a raspberry pi 2 model B where ROS Indigo is already installed. I've followed the following walkthroughs with no success:

Rosdeps all installed fine and here's my latest build error:

$ catkin_make 
Base path: /home/ubuntu/catkin_ws
Source space: /home/ubuntu/catkin_ws/src
Build space: /home/ubuntu/catkin_ws/build
Devel space: /home/ubuntu/catkin_ws/devel
Install space: /home/ubuntu/catkin_ws/install
####
#### Running command: "make cmake_check_build_system" in "/home/ubuntu/catkin_ws/build"
####
####
#### Running command: "make -j4 -l4" in "/home/ubuntu/catkin_ws/build"
####
[  0%] [  0%] [  0%] Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_b
Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_f
Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui
[  0%] Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_s
[  1%] [  8%] Built target rgbdslam_generate_messages_cpp
[ 16%] Built target rgbdslam_generate_messages_py
Performing build step for 'siftgpu_proj'
[ 22%] Built target rgbdslam_generate_messages_lisp
make[3]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
[ 22%] Built target rgbdslam_gencpp
g++: error: unrecognized command line option '-mfpmath=sse'
make[3]: *** [build/FrameBufferObject.o] Error 1
make[2]: *** [rgbdslam_v2/external/siftgpu_prefix/src/siftgpu_proj-stamp/siftgpu_proj-build] Error 2
make[1]: *** [rgbdslam_v2/external/CMakeFiles/siftgpu_proj.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 22%] Built target rgbdslam_generate_messages
[ 24%] [ 26%] [ 27%] [ 29%] Building CXX object rgbdslam_v2/CMakeFiles/rgbdslam.dir/src/moc_graph_manager.cxx.o
Building CXX object rgbdslam_v2/CMakeFiles/rgbdslam.dir/src/moc_glviewer.cxx.o
Building CXX object rgbdslam_v2/CMakeFiles/rgbdslam.dir/src/qtros.cpp.o
Building CXX object rgbdslam_v2/CMakeFiles/rgbdslam.dir/src/openni_listener.cpp.o
c++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.8/README.Bugs> for instructions.
make[2]: *** [rgbdslam_v2/CMakeFiles/rgbdslam.dir/src/moc_graph_manager.cxx.o] Error 4
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [rgbdslam_v2/CMakeFiles/rgbdslam.dir/all] Error 2
make: *** [all] Error 2
make: INTERNAL: Exiting with 5 jobserver tokens available; should be 4!
Invoking "make -j4 -l4" failed

Second attempt using -j1

$ catkin_make -j1
Base path: /home/ubuntu/catkin_ws
Source space: /home/ubuntu/catkin_ws/src
Build space: /home/ubuntu/catkin_ws/build
Devel space: /home/ubuntu/catkin_ws/devel
Install space: /home/ubuntu/catkin_ws/install
####
#### Running command: "make cmake_check_build_system" in "/home/ubuntu/catkin_ws/build"
####
####
#### Running command: "make -j1" in "/home/ubuntu/catkin_ws/build"
####
[  0%] Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_f
[  0%] Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui
[  0%] Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_s
[  0%] Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_b
[  6%] Built target rgbdslam_generate_messages_cpp
[  6%] Built target rgbdslam_gencpp
[  8%] Building CXX object rgbdslam_v2/CMakeFiles/rgbdslam.dir/src/moc_graph_manager.cxx.o
[  9%] Building CXX object rgbdslam_v2/CMakeFiles/rgbdslam.dir/src/qt_gui.cpp.o
[ 11%] Building CXX object rgbdslam_v2/CMakeFiles/rgbdslam.dir/src/node.cpp.o
[ 13%] Building CXX object rgbdslam_v2/CMakeFiles/rgbdslam.dir/src/glviewer.cpp.o
In file included from /usr/include/GL/freeglut_std.h:128:0,
                 from /usr/include/GL/glut.h:17,
                 from /home/ubuntu/catkin_ws/src/rgbdslam_v2/src/glviewer.cpp:24:
/usr/include/GL/gl.h:138:17: error: conflicting declaration 'typedef double ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-04-05 10:12:27 -0500

gvdhoorn gravatar image

updated 2017-02-12 06:47:06 -0500

Bit late perhaps, but this could very well be due to your platform not having enough memory to compile all of this. Do you have swap enabled?


(very late) Edit:

g++: error: unrecognized command line option '-mfpmath=sse'

just noticed this line in your "first attempt": sse is an Intel/AMD only instruction set, and is not supported by ARM CPUs.

The other attempts to indeed point to incompatibilities between OpenGL ES and other versions, as @Humpelstilzchen remarked.

edit flag offensive delete link more

Comments

The first maybe, the second run looks like an incompatibility with opengl es. There probably is no easy solution for this.

Humpelstilzchen gravatar imageHumpelstilzchen ( 2016-04-05 14:17:55 -0500 )edit

I noticed that I receive a different error on the Jetson TK1 which is quad for with more ram. I posted the findings in an edit to my original question. I'm going to try an rpi3 tomorrow as well.

jacksonkr_ gravatar imagejacksonkr_ ( 2016-04-05 20:40:42 -0500 )edit

I tried Humpelstilzchen's suggest with no solution. I'm still stuck, witht he Jetson K1 even.

jacksonkr_ gravatar imagejacksonkr_ ( 2016-04-08 14:08:00 -0500 )edit

Hello! I have the same problems with Jetson TK1. Did you resolve them?

bogdan gravatar imagebogdan ( 2016-08-31 05:51:10 -0500 )edit

I can't remember what I did but it works now on the Jetson TK1. I'm using Ubuntu 14.04 and ROS Indigo. I can install with using the rgbdslam package for ros as well as compiling rgbdslam from the github source.

jacksonkr_ gravatar imagejacksonkr_ ( 2016-08-31 09:49:35 -0500 )edit

@jacksonkr_ How was RGBDSLAM performance on TK1? Did you try to install on TX1(Ubuntu16.04/JetPack2.3.1/ROS:Kinetic)? What kind version of Kinect did you use?

Juno Kr gravatar imageJuno Kr ( 2017-01-03 19:57:10 -0500 )edit

RGBDSLAM performance is GREAT and would understandably be even better on the TX1. Kinect v1 model 1414 is my favorite to work with. I've also used Kinect v2 and Intel r200. I encourage Kinect v1 because it uses laser while the other two use infrared bulbs.

jacksonkr_ gravatar imagejacksonkr_ ( 2017-01-05 08:34:10 -0500 )edit
0

answered 2017-02-13 01:16:10 -0500

To get around the sse error you need to go into src/external/SiftGPU/makefile and comment out lines 19 and 20. Arm doesn't have these extended floating point instructions. Also in the CMakeLists.txt in the top level directory uncomment line 30 and comment the one right under it that is uncommitted. Don't remember which number I've slept since I did this :) That will get it to build on ARM. Lots of options for this puppy. Sucks for me though although the Zed is openNi compatible there is no driver for it and I can't even find source for the drivers included to see if I can cobble up one. Tried remapping the streams coming out of the zed_wrapper thinking that might do what openni is doing. But something isn't right it crashes immediately when you start the camera. So I guess I'll have to look at another SLAM or just stick with rtabmap it works great.

edit flag offensive delete link more

Comments

Hi! I would like to know what kind of crash/error you experienced when starting RGBDSLAM. I tried installing it on 2 different machines and I get this error while starting launch files. Since I'm considering installing it on RPi3 I want to know if it is worth a try.

Dox gravatar imageDox ( 2018-04-07 13:05:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-04-02 12:52:50 -0500

Seen: 1,248 times

Last updated: Feb 13 '17