Ask Your Question
0

Octomap visualization doesn't display anything - rgbdslam

asked 2013-05-22 10:24:02 -0500

Zayin gravatar image

updated 2014-01-28 17:16:36 -0500

ngrennan gravatar image

I have the same problem as described here: http://answers.ros.org/question/53228/rgbdslam-cannot-produce-octomap/. However, when I execute rostopic echo /rgbdslam/batch_clouds, a long list of integers is outputted so I assume this is working. I don't understand why octomap viewer only contains an empty blue cube when I try to load the octomap I saved. How can I fix this?

Edit: I have attached a screenshot of the rxgraph: Rxtgraph

By the way, I get this output when saving the octomap, but I don't see /octomap_binary in the graph. Is that the issue?

rosrun octomap_server octomap_saver test2.bt
[ INFO] [1369321237.790118097]: Requesting the map from /octomap_binary...
[ INFO] [1369321237.809273887]: Map received, saving to test2.bt

Edit 2: I just found this topic: http://answers.ros.org/question/9965/how-to-get-octomap-to-store-data-sent-by-rgbdslam/. I downloaded Octomap using apt-get install; do I need another version?

Edit 3: This is the output I get from launching openni:

SUMMARY
========

PARAMETERS
 * /camera/depth/rectify_depth/interpolation
 * /camera/depth_registered/rectify_depth/interpolation
 * /camera/disparity_depth/max_range
 * /camera/disparity_depth/min_range
 * /camera/disparity_depth_registered/max_range
 * /camera/disparity_depth_registered/min_range
 * /camera/driver/depth_camera_info_url
 * /camera/driver/depth_frame_id
 * /camera/driver/depth_registration
 * /camera/driver/device_id
 * /camera/driver/rgb_camera_info_url
 * /camera/driver/rgb_frame_id
 * /rosdistro
 * /rosversion

NODES
  /camera/depth/
    metric (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    points (nodelet/nodelet)
    rectify_depth (nodelet/nodelet)
  /camera/rgb/
    debayer (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
    rectify_mono (nodelet/nodelet)
  /
    camera_base_link (tf/static_transform_publisher)
    camera_base_link1 (tf/static_transform_publisher)
    camera_base_link2 (tf/static_transform_publisher)
    camera_base_link3 (tf/static_transform_publisher)
    camera_nodelet_manager (nodelet/nodelet)
  /camera/
    disparity_depth (nodelet/nodelet)
    disparity_depth_registered (nodelet/nodelet)
    driver (nodelet/nodelet)
    points_xyzrgb_depth_rgb (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
  /camera/ir/
    rectify_ir (nodelet/nodelet)
  /camera/depth_registered/
    metric (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    rectify_depth (nodelet/nodelet)

core service [/rosout] found
process[camera_nodelet_manager-1]: started with pid [20137]
process[camera/driver-2]: started with pid [20138]
process[camera/rgb/debayer-3]: started with pid [20166]
[ INFO] [1369429911.881946647]: Initializing nodelet with 4 worker threads.
process[camera/rgb/rectify_mono-4]: started with pid [20203]
process[camera/rgb/rectify_color-5]: started with pid [20225]
process[camera/ir/rectify_ir-6]: started with pid [20280]
process[camera/depth/rectify_depth-7]: started with pid [20355]
process[camera/depth/metric_rect-8]: started with pid [20425]
process[camera/depth/metric-9]: started with pid [20459]
process[camera/depth/points-10]: started with pid [20515]
process[camera/register_depth_rgb-11]: started with pid [20541]
process[camera/depth_registered/rectify_depth-12]: started with pid [20561]
process[camera/depth_registered/metric_rect-13]: started with pid [20621]
process[camera/depth_registered/metric-14]: started with pid [20647]
process[camera/points_xyzrgb_depth_rgb-15]: started with pid [20667]
process[camera/disparity_depth-16]: started with pid [20728]
process[camera/disparity_depth_registered-17]: started with pid [20757]
process[camera_base_link-18]: started with pid [20815]
process[camera_base_link1-19]: started with pid [20834]
process[camera_base_link2-20]: started with pid [20852]
process[camera_base_link3-21]: started with pid [20907]
[ERROR] [1369429921.870903205]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressedDepth/set_parameters]
[ERROR] [1369429921.918984524]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters]
[ERROR] [1369429921.962493901]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/theora/set_parameters]

However, the GUI is listening ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-05-22 22:29:50 -0500

It shows an empty cube when no data has been received. Check that the right topics are connected (rxgraph is a good tool for that) and that the tf frames are correctly set.

By the way: In the latest rgbdslam version you can save an octomap directly from the rgbdslam gui and do not need the external octomap server.

edit flag offensive delete link more

Comments

Thanks for your reply! I have included a screenshot of the rgbdslam/octomap graph. It seems fine to me, isn't it? How can I save the map directly as .bt or .ot? I just see .PCD, .PLY, .XML and .YAML in the GUI save options. Would that mean I don't have the latest version?

Zayin gravatar imageZayin ( 2013-05-23 04:44:37 -0500 )edit

In the latest version there is a gui option "Save Octomap". Get it from "ros.org/wiki/rgbdslam". It doesn't require starting an external octomap_server, as rgbdslam uses it as a library. This reduces a lot of interface problems, e.g. setting the right frames, dropped messages...

Felix Endres gravatar imageFelix Endres ( 2013-05-24 04:17:32 -0500 )edit

That's funny, I got my version from there a few days ago. I'll try again. [Edit] I redownloaded it, and it's the same; no save octomap option.

Zayin gravatar imageZayin ( 2013-05-24 04:42:28 -0500 )edit

Are you positive you aren't confusing different versions? It's definitely in there. Check the source (e.g. search src/qt_gui.cpp for "Save Octomap"). See also http://alufr-ros-pkg.googlecode.com/svn/trunk/rgbdslam_freiburg/rgbdslam/src/qt_gui.cpp

Felix Endres gravatar imageFelix Endres ( 2013-05-24 09:49:49 -0500 )edit

"Save octomap" is not in my qt_gui.cpp. I've downloaded the package with this command: svn co http://alufr-ros-pkg.googlecode.com/svn/trunk/rgbdslam_freiburg. I'll just delete my entire package and try again. [Edit] Alright, that 3rd download did it! That was weird.

Zayin gravatar imageZayin ( 2013-05-24 10:17:58 -0500 )edit

I have a new problem now; I get no output from the camera in the GUI. I think the topics might not be compatible, I'll post the list in my initial post. What do you think? I'm done for the week, I'll be back on Monday. Thanks a lot!!!

Zayin gravatar imageZayin ( 2013-05-24 11:13:55 -0500 )edit

You can set the topics rgbdslam subscribes to in the launch file. See the existing ones for examples.

Felix Endres gravatar imageFelix Endres ( 2013-05-25 05:56:26 -0500 )edit

After a fresh restart, the problem has fixed itself. I can now see the images in the GUI as well as view the octomap with Octovis! Thank you so much for your help!!! I have another question for you, I will create a new topic in a few minutes.

Zayin gravatar imageZayin ( 2013-05-27 05:17:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-05-22 10:24:02 -0500

Seen: 967 times

Last updated: May 24 '13