Ask Your Question
0

cannot find octovis for viewing the built map

asked 2012-07-20 00:00:15 -0500

Sudhan gravatar image

updated 2012-07-20 00:04:34 -0500

AHornung gravatar image

I am using ros-fuerte. I used rgbdslam package to built a map. I saved the map as 'name.bt'. When I am trying to view it using rosrun octovis octovis <filename.bt>

I got the error octovis stack/package not found.

But I checked the installed location using '$ dpkg -L ros-fuerte-octovis'

I got output as:

/. /usr /usr/share /usr/share/doc /usr/share/doc/ros-fuerte-octovis /usr/share/doc/ros-fuerte-octovis/changelog.Debian.gz /usr/share/doc/ros-fuerte-octovis/copyright /opt /opt/ros /opt/ros/fuerte /opt/ros/fuerte/bin /opt/ros/fuerte/bin/octovis /opt/ros/fuerte/include /opt/ros/fuerte/include/octovis /opt/ros/fuerte/include/octovis/TrajectoryDrawer.h /opt/ros/fuerte/include/octovis/ColorOcTreeDrawer.h /opt/ros/fuerte/include/octovis/SelectionBox.h /opt/ros/fuerte/include/octovis/OcTreeDrawer.h /opt/ros/fuerte/include/octovis/OcTreeRecord.h /opt/ros/fuerte/include/octovis/PointcloudDrawer.h /opt/ros/fuerte/include/octovis/SceneObject.h /opt/ros/fuerte/lib /opt/ros/fuerte/lib/liboctovis.a /opt/ros/fuerte/lib/cmake /opt/ros/fuerte/lib/cmake/octovis /opt/ros/fuerte/lib/cmake/octovis/octovis-config.cmake /opt/ros/fuerte/lib/cmake/octovis/octovis-config-version.cmake /opt/ros/fuerte/lib/liboctovis.so

Is there any possible solutions?

edit retag flag offensive close merge delete

2 Answers

Sort by ┬╗ oldest newest most voted
2

answered 2012-07-20 00:04:14 -0500

AHornung gravatar image

You no longer start octovis as a ROS package in fuerte (i.e. with "rosrun"). It is now installed as a regular system-wide library, so you start it just like any other program:

octovis <filename.bt>
edit flag offensive delete link more

Comments

Initially, I tried that too and also now. But, I got the same error, ERROR: Filestream to 1stmap.bt not open, nothing read.

Sudhan gravatar imageSudhan ( 2012-07-20 00:58:57 -0500 )edit

Sorry. In the mapping process instead of using openni_node.launch, I used openni.launch from other package. So, I guess the map was not built. But, I cannot find the file openni_node.launch in openni_camera package.

Sudhan gravatar imageSudhan ( 2012-07-20 01:25:08 -0500 )edit

That is a completely different problem, I guess. What happens if you open octovis (without filename), then go the File / Open and pick your file?

AHornung gravatar imageAHornung ( 2012-07-20 01:36:35 -0500 )edit

I solved the problem. I cannot find openni_node.launch because its located in the package openni_camera_deprecated. But, in older versions its located in openni_camera. So, try for $ roslaunch openni_camera_deprecated openni_node.launch

Sudhan gravatar imageSudhan ( 2012-07-20 02:14:34 -0500 )edit
0

answered 2014-09-06 00:26:04 -0500

Currently you can run install and run Octomap indenpendently.

Steps: $ git clone git://github.com/OctoMap/octomap.git $cd octomap $mkdir build $cd build $cmake .. $make

Then you can find executable files in the octomap/bin

For instance, you can download the dataset from http://ais.informatik.uni-freiburg.de...

Then run $ ./octovis geb079_max50m.graph (the name of dataset)

Or you can also see the simple_example by running $./simple example

generating example map

performing some queries: occupancy probability at (0 0 0): 0.971 occupancy probability at (-1 -1 -1): 0.1192 occupancy probability at (1 1 1): is unknown

wrote example file simple_tree.bt

Then run $ ./octovis simple_tree.bt

To view the tree:)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-20 00:00:15 -0500

Seen: 1,716 times

Last updated: Sep 06 '14