ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

PR2 self-filtering problem

asked 2013-12-29 19:09:13 -0500

Ronald_Chan gravatar image

updated 2014-11-22 17:05:30 -0500

ngrennan gravatar image

Hi, I am a newer using Moveit on PR2 As i am studying on object manipulation recently, the first thing i need to do is to filter PR2 's arm out of the point cloud read by the kinect

I try to solve this problem by creating a sensors_rgbd.yaml into pr2_moveit_generated/config , like this

 - sensor_plugin: occupancy_map_monitor/PointCloudOctomapUpdater
   point_cloud_topic: /head_mount_kinect/depth_registered/points
   max_range: 5.0
   padding_offset: 0
   padding_scale: 1.5
   point_subsample: 1
   filtered_cloud_topic: output_cloud

and the result is shown in rviz . However, it seems that PR2 's arm is not filtered well, a majority of the hand is still here

image description

May i ask what should i do in order to get a better filtered point cloud?? thanks a lot!!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-10-26 09:05:16 -0500

hauff gravatar image

Just for completeness, that should work ...

padding_offset: 0.02
edit flag offensive delete link more

Question Tools

1 follower


Asked: 2013-12-29 19:09:13 -0500

Seen: 352 times

Last updated: Dec 29 '13