Ask Your Question
1

Can't manage to install teleop_base package

asked 2011-09-28 00:26:06 -0500

jlo gravatar image

updated 2011-09-28 01:02:30 -0500

Hey guys, I'm new to ROS and I recently finished the documentation's tutorial. My next step would be to try some ROS functionalities in a simulator before putting them to practice with a real robot. I tried to follow the 'stage' tutorial (here), but I can't get past the step after 'rosmake stage'. I don't know how to 'install' the teleop_base package. I get that with svn you check the version and in the link there are the files, but... is there a simple command to do this or do I download everything and include its path in $ROS_PACKAGE_PATH?

Here's what pops up when I try 'rosmake teleop_base'

'[ rosmake ] Packages requested are: ['teleop_base']
[ rosmake ] Logging to directory/home/alonsoj1/.ros/rosmake/rosmake_output-20110928-154556 [ rosmake ] Expanded args ['teleop_base'] to: []
[ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['teleop_base']
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

What does this mean? I just would like to be able to control the robot with the keyboard.

Thanks!

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
0

answered 2011-09-28 03:36:45 -0500

DimitriProsser gravatar image

You need to include the new directory in your ROS_PACKAGE_PATH. I do this by adding the following to my .bashrc:

export ROS_PACKAGE_PATH=/home/myuser/mypackagesdirectory:$ROS_PACKAGE_PATH

or

export ROS_PACKAGE_PATH=/home/myuser/mypackagesdirectory:/opt/ros/diamondback/stacks

(Don't forget to source your .bashrc after adding this line)

edit flag offensive delete link more
1

answered 2011-10-03 02:28:43 -0500

jlo gravatar image

updated 2011-10-03 02:37:49 -0500

I finally could (I changed the stack directory again, so I had to refresh the bashrc). Once I did that I came up with a problem compiling teleop_base (it needed joy), so I went here and installed it. It still got some 'warnings', but now it teleop_base_keyboard runs finally :).

It doesn't respond for now, but I'm sure I'll figure it out somehow. (EDIT: fixed, the problem I had was that when I opened teleop_base_keyboard I pressed a keystroke that wasn't part of the ones that you're supposed to press to move the robots, so the program stops and wouldn't respond)

Thanks A LOT :)!!! (I was completely lost in the woods there for a while)

PS: Sorry for that incomplete answer, I had a problem before with the session and I realized half through writing the answer what was wrong. Everything is fixed now!!! Again, thanks!

edit flag offensive delete link more
0

answered 2011-10-02 19:35:38 -0500

jlo gravatar image

Thanks for the quick answer. I tried your solution, but it doesn't seem to work (I remembered to resource the bashrc). I still get the same result as posted in my first message when I execute 'rosmake teleop'.

Could it have to do with me using electric distro? I tried to install the package as explained here, but it didn't work.

Any ideas/suggestions? I honestly don't know what else I could do.

Thanks!

edit flag offensive delete link more

Comments

Can you use "roscd teleop_base"?
DimitriProsser gravatar imageDimitriProsser ( 2011-10-03 01:47:21 -0500 )edit
I finally could (I changed the stack directory again, so I had to refresh the bashrc), but now I come up with the following problem:
jlo gravatar imagejlo ( 2011-10-03 02:05:00 -0500 )edit
What is the new problem? Or is it the same problem?
DimitriProsser gravatar imageDimitriProsser ( 2011-10-03 02:16:43 -0500 )edit
0

answered 2011-10-24 22:06:54 -0500

marcobecerrap gravatar image

Hi, I had the same problem trying to run this tutorial. But I still can't find how to install the 'joy' package... could anyone please post the correct way to do this?

thnx

edit flag offensive delete link more
0

answered 2011-10-24 23:04:55 -0500

jlo gravatar image

Basically when you have to install a package, you go to the directory you want it in (for example, ~/ros_workspace/) and then write 'svn co <link>' that you find in the page of the package http://www.ros.org/wiki/joy. In this case:

svn co https://code.ros.org/svn/ros-pkg/stacks/joystick_drivers/trunk/joy

If after this it still doesn't work, let me know.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-09-28 00:26:06 -0500

Seen: 1,536 times

Last updated: Oct 24 '11